Задана последовательность из 10 целых чисел?

Информатика | 10 - 11 классы

Задана последовательность из 10 целых чисел.

Для каждого элемента начиная со второго найти разницу с предыдущим элементом (ai - ai - 1).

Ответить на вопрос
Ответы (2)
Ammogerl97 14 окт. 2020 г., 08:21:43

Ответ пишу в комментариях, использовал массив, так проще).

На входе вводишь 10 чисел на выходе 5 разниц.

Если сделал что - то не так, пиши поправлю!

Gaik69 14 окт. 2020 г., 08:21:47

Const n = 10 ;

var a : array[1.

N] of integer ;

i : integer ;

begin

Randomize ;

for i : = 1 to n do

begin

a[i] : = random(51) ;

write(a[i] : 4) ;

end ;

writeln ;

writeln('Искомые разности : ') ;

for i : = 2 to n do write(a[i] - a[i - 1] : 4) ;

writeln ;

end.

Пример : 3 43 32 33 18 29 21 48 33 28

Искомые разности : 40 - 11 1 - 15 11 - 8 27 - 15 - 5.

Макс451564 3 янв. 2020 г., 16:14:15 | 10 - 11 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Класс2003 31 июл. 2020 г., 05:56:09 | 10 - 11 классы

Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов?

Напишите программу формирования и вывода двумерного массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов.

Два первых элемента задайте с клавиатуры.

Red1374 2 янв. 2020 г., 07:12:40 | 1 - 4 классы

Задача А МаксМин Дается последовательность из N чисел?

Задача А МаксМин Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Владленка76 28 мая 2020 г., 03:15:05 | 10 - 11 классы

Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов?

Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов.

Два первых элемента задайте с клавиатуры.

Напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу : 1 - й - равен случайному числу, отличному от нуля ; 2 - й - равен квадрату предыдущего элемента ; 3 - й - равен целой части частного от деления двух предыдущих элементов.

Borys953 13 дек. 2020 г., 23:55:42 | 10 - 11 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Paramonoff4 14 июн. 2020 г., 06:59:12 | 10 - 11 классы

Задана последовательность из n целых чисел?

Задана последовательность из n целых чисел.

Определить среднее арифметическое отрицательных элементов последовательности.

Написать программу в Pascal.

LishkaJoyble 19 дек. 2020 г., 03:00:09 | 10 - 11 классы

Вводится последовательность из N положительных целых чисел?

Вводится последовательность из N положительных целых чисел.

Найти наименьшее число среди чётных элементов последовательности.

Evohka3333 27 янв. 2020 г., 17:48:56 | 5 - 9 классы

Задан массив целых чисел из N элементов?

Задан массив целых чисел из N элементов.

Найти все непарные элементы массива.

Сложить блок - схему алгоритма решения задачи.

Dyrugin05 12 авг. 2020 г., 19:55:50 | 5 - 9 классы

Паскаль Вывести значение каждого третьего элемента последовательности, начиная с первого?

Паскаль Вывести значение каждого третьего элемента последовательности, начиная с первого.

Ваня507 30 окт. 2020 г., 00:39:52 | 5 - 9 классы

Язык python 3?

Язык python 3.

1 : Последовательность состоит из натуральных чисел и завершается числом 0.

Определите, сколько элементов этой последовательности больше предыдущего элемента.

Решите пожалуйста.

На этой странице сайта вы найдете ответы на вопрос Задана последовательность из 10 целых чисел?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.