Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста.

Напишите программу по которой из текстового файла с именем kvur.

Txt будут прочитаны три числа : a, b, c - коэффициенты квадратного уравнения затем будут вычислены корни этого уравнения и выведены на экран и в текстовый файл korni.

Txt. на паскале.

Ответить на вопрос
Ответы (1)
Nik210123 13 окт. 2020 г., 09:42:40

Если данное уравнение не имеет корней, выведите число 0.

Если уравнение имеет один корень, выведите число 1, а затем этот корень.

Если уравнение имеет два корня, выведите число 2, а затем два корня в порядке возрастания.

Если уравнение имеет бесконечно много корней, выведите число 3.

Program gt ;

var a, b, c, d, x1, x2, s : real ; label 1, 2 ;

begin

read(a, b, c) ;

if ((a = 0)and(b = 0)and(c< ; > ; 0)) then writeln(0) ;

if(a = 0)and(b = 0)and(c = 0)then writeln(3) ;

if(a< ; > ; 0)and(b< ; > ; 0)and(c< ; > ; 0)then begin

d : = b * b - 4 * a * c ;

if (d< ; 0)or((a = 0)and(b = 0)and(c< ; > ; 0)) then writeln(0) ;

if d> ; = 0 then begin

x1 : = ( - b + sqrt(d)) / (2 * a) ;

x2 : = ( - b - sqrt(d)) / (2 * a) ;

if x1 = x2 then write(1, ' ', x1) ;

if (x1< ; > ; x2)and(x1< ; x2) then write(2, ' ', x1, ' ', x2) ;

if (x1< ; > ; x2)and(x1> ; x2) then write(2, ' ', x2, ' ', x1) ;

end ;

end ;

if (a = 0)and(b< ; > ; 0)and(c< ; > ; 0)then begin

x1 : = - c / b ;

write(1, ' ', x1) ;

end ;

if (a< ; > ; 0)and(b = 0)and(c< ; > ; 0)then begin

if( - c / a> ; = 0) then begin

x2 : = sqrt( - c / a) ;

x1 : = - sqrt( - c / a) ;

if (x1< ; > ; x2)and(x1< ; x2) then write(2, ' ', x1, ' ', x2) ;

if (x1< ; > ; x2)and(x1> ; x2) then write(2, ' ', x2, ' ', x1) ;

end ;

if( - c / a< ; 0) then writeln(0) ;

end ;

if (a< ; > ; 0)and(b< ; > ; 0)and(c = 0)then begin

x1 : = 0 ;

x2 : = - b / a ;

if (x1< ; > ; x2)and(x1< ; x2) then write(2, ' ', x1, ' ', x2) ;

if (x1< ; > ; x2)and(x1> ; x2) then write(2, ' ', x2, ' ', x1) ;

end ;

end.

Leilaadaletovna 22 сент. 2020 г., 18:57:57 | 5 - 9 классы

В файле input?

В файле input.

Txt записаны строки сколько их неизвестно заменить все слова короче на в общем и записать результат в файл output.

Txt на языке ПАСКАЛЬ.

КотеВнайках 25 мар. 2020 г., 09:58:44 | 10 - 11 классы

Отметьте правильную запись имени текстового файла?

Отметьте правильную запись имени текстового файла?

1) basa - com ; 2) basa.

Txt ; 3) : basa.

Txt ; 4)BASA.

SYS.

Iolantakoshele 16 дек. 2020 г., 01:18:32 | 10 - 11 классы

Полный путь к файлу C : DOCPROBA?

Полный путь к файлу C : DOCPROBA.

TXT Каково имя каталога, в котором находится файл PROBA.

TXT? .

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Edifier 27 окт. 2020 г., 18:04:37 | 10 - 11 классы

ПОМОГИТЕ СРОЧНЯК?

ПОМОГИТЕ СРОЧНЯК!

Составить программу, которая подсчитывает в имеющимся файле количество чисел и выводит ответ на экран и в файл output.

Txt.

Rustam181 3 июн. 2020 г., 22:35:40 | 1 - 4 классы

Ребят, помогите, пожалуйста, написать типы исполнительных файлов, системных файлов, текстовых, графических, видео файлов, аудио файлов, файлов на языке программирования и архивных файлов?

Ребят, помогите, пожалуйста, написать типы исполнительных файлов, системных файлов, текстовых, графических, видео файлов, аудио файлов, файлов на языке программирования и архивных файлов.

Например : Текстовые файлы : doc.

Txt.

Nadezdasang 26 янв. 2020 г., 13:43:07 | 10 - 11 классы

Помогите решить кто знает паскаль Вот задача Дан файл с оценками ?

Помогите решить кто знает паскаль Вот задача Дан файл с оценками .

Txt учащихся Написать программу которая определяет количество пятерок, четвёрок, троек.

Вывести их количество на экран.

Нужно написать в текстовом документе а с помощью Паскаля это прочитать Пожалуйста!

NikUFO 18 апр. 2020 г., 22:24:10 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЬ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЬ!

Нахождение суммы чисел в матрице, ввод чисел осуществить из файла matrix.

Txt вывод на экран.

Herringbone 21 дек. 2020 г., 12:54:18 | 5 - 9 классы

Путь к файлу колобок?

Путь к файлу колобок.

Txt. И какое полное имя файла колобок.

Txt.

Ренатусь 25 окт. 2020 г., 21:08:52 | 5 - 9 классы

К форматам текстовых файлов относятся :1?

К форматам текстовых файлов относятся :

1.

Txt, doc, odt, xls

2.

Txt, odt, docx, rtf

3.

Doc, docx, xls, rtf

4.

Txt, doc, jpg, rtf.

Вы зашли на страницу вопроса Помогите пожалуйста?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.