Дана строка, заканчивающаяся точкой?

Информатика | 10 - 11 классы

Дана строка, заканчивающаяся точкой.

Подсчитать, сколько в ней слов.

Ответить на вопрос
Ответы (1)
Удача 8 июл. 2020 г., 09:08:17

Считаем, что слова разделяются ровно одним пробелом.

Тогда слов будет на единицу больше, чем пробелов.

Var i, n, p, k : integer ; s : string ;

begin Write('Введите предложение и закончите его точкой : ') ; Readln(s) ; s : = Trim(s) ; p : = Pos('.

', s) - 1 ; k : = 0 ; for i : = 1 to p do if s[i] = ' ' then k : = k + 1 ; Writeln('Введено слов - ', k + 1)

end.

Тестовое решение :

Введите предложение и закончите его точкой : Карл у Клары украл кораллы.

Введено слов - 5.

Bibgul1981 4 авг. 2020 г., 11:23:33 | 10 - 11 классы

В строке заменить все двоеточие( : )точкой с запятой ( ; )Подсчитать количество замен?

В строке заменить все двоеточие( : )точкой с запятой ( ; )Подсчитать количество замен.

Dilya03276 24 февр. 2020 г., 02:57:42 | 5 - 9 классы

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL?

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL.

Lyudamininaa 19 июн. 2020 г., 02:48:51 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Подсчитать количество вхождений буквы "n".

Кицюня095 23 янв. 2020 г., 07:00:42 | 5 - 9 классы

Дана строка?

Дана строка.

Подсчитать количество слов , начинающихся с буквы Б.

11sobachka 18 янв. 2020 г., 19:09:07 | 10 - 11 классы

Нужно написать на Паскале = ))Дан набор слов, разделенных точкой с запятой ( ; ), который заканчивается двоеточием ( : )?

Нужно написать на Паскале = ))

Дан набор слов, разделенных точкой с запятой ( ; ), который заканчивается двоеточием ( : ).

Определить, сколько в нем слов, заканчивающихся буквой «а».

Nishpor79 13 авг. 2020 г., 04:30:09 | 10 - 11 классы

Дана строка, заканчивающаяся точкой?

Дана строка, заканчивающаяся точкой.

Подсчитать, сколько слов в строке.

(язык С + + ).

87786095109 2 дек. 2020 г., 00:42:45 | 10 - 11 классы

Помогите написать программу в pascal?

Помогите написать программу в pascal.

Дан набор слов, разделенных точкой с запятой ( ; ).

Набор заканчивается двоеточием ( : ).

Определить, сколько в нем слов, заканчивающихся буквой а.

Camal111 4 мая 2020 г., 15:15:19 | 5 - 9 классы

Дан текстовый файл?

Дан текстовый файл.

Подсчитать количество символов в каждой строке.

Sesnation 19 авг. 2020 г., 09:04:03 | 5 - 9 классы

Дано предложение - строка?

Дано предложение - строка.

Подсчитать количество слов, начинающихся с буквы 'а' написать программу на паскале.

Kiti2259 24 июн. 2020 г., 06:59:43 | 10 - 11 классы

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке?

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке.

На этой странице находится ответ на вопрос Дана строка, заканчивающаяся точкой?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.