Получение алгоритма для обработки величин с реализацией на языке программирование?

Информатика | 5 - 9 классы

Получение алгоритма для обработки величин с реализацией на языке программирование.

Работу нужно выполнить в программе pascal ABC.

Дайте пожалуйста готовый, не сложный для того, чтобы выучить алгоритм.

Буду очень благодарен.

Ответить на вопрос
Ответы (1)
Kralem 17 янв. 2020 г., 20:35:15

Очень простой алгоритм :

Program Alexey ;

{программа запрашивает у пользователя значения ежедневной температуры за 14 дней, и выводит максимальное и минимальное значения и в какие дни температруа достигала этих значений, а также вычисляет среднюю температуру за 2 недели}

uses crt ;

const n = 14 ;

var i, daymax, daymin : integer ; t, max, min, sum : real ;

begin writeln('Введите температуру за каждый день') ; write('День 1 - й : T = ') ; readln(t) ; max : = t ; min : = t ; sum : = t ; for i : = 2 to 14 do / / организуем цикл begin write('День ', i, ' - й : T = ') ; readln(t) ; if t> ; max then begin max : = t ; / / найдено новое максимальное значение daymax : = i ; / / запоминаем соответствующий номер дня end ; if t< ; min then begin min : = t ; / / найдено новое минимальное значение daymin : = i ; / / запоминаем соответствующий номер дня end ; sum : = sum + t ; / / суммируем все значения t end ; writeln() ; writeln('Максимальная температура была на ', daymax, ' - й день : ', max, ' градусов') ; writeln('Минимальная температура была на ', daymin, ' - й день : ', min, ' градусов') ; writeln('Средняя температура за 14 дней : ', sum / 14, ' градусов') ;

end.

Ldfdg 25 июн. 2020 г., 08:53:10 | 5 - 9 классы

Составить программу на языке программирования Паскаль , которая бы соответствовала бы следующему алгоритму?

Составить программу на языке программирования Паскаль , которая бы соответствовала бы следующему алгоритму.

Aibolatiki 31 июл. 2020 г., 08:13:52 | 10 - 11 классы

Нужна помощь, буду очень благодарен?

Нужна помощь, буду очень благодарен.

Создайте файл f, компоненты которого являются действительными числами.

Напишите программу вычисления суммы компонентов файла f и произведения ненулевых компонентов этого файла.

Язык программирования : Pascal.

Alexander2003 4 сент. 2020 г., 00:31:49 | 5 - 9 классы

1. Свойства алгоритма и его характеристика 2?

1. Свойства алгоритма и его характеристика 2.

Что такое алгоритм?

3. Типы алгоритмов 4.

Виды языков программирования.

Смп 27 июл. 2020 г., 07:26:55 | 10 - 11 классы

Pascal нужно написать программу с алгоритмом 3?

Pascal нужно написать программу с алгоритмом 3.

1 и 3.

2 , 6

Нужно очень очень.

Подробно если можно.

ДАНЯ12134 6 апр. 2020 г., 22:16:09 | 5 - 9 классы

Написать алгоритм действий для програмы Pascal ABC?

Написать алгоритм действий для програмы Pascal ABC.

Слово "МОЛОКО".

ScRaP 20 апр. 2020 г., 17:23:45 | 10 - 11 классы

Очень срочно, пожалуйста(((Составить алгоритм и программу?

Очень срочно, пожалуйста(((Составить алгоритм и программу.

Daha097641 10 авг. 2020 г., 09:25:31 | 10 - 11 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА, очень срочно нужно написать программу в Pascal(ABC)?

ПОМОГИТЕ, ПОЖАЛУЙСТА, очень срочно нужно написать программу в Pascal(ABC).

Катёнок8888 24 мар. 2020 г., 01:33:07 | 10 - 11 классы

Составить по алгоритму программу на языке программирования Pascal?

Составить по алгоритму программу на языке программирования Pascal.

Infoplan 26 сент. 2020 г., 16:48:23 | 5 - 9 классы

Составить по алгоритму программу на языке программирования Pascal?

Составить по алгоритму программу на языке программирования Pascal.

Zemfirka20011 22 дек. 2020 г., 04:05:29 | 5 - 9 классы

Помогите выполнить алгоритм?

Помогите выполнить алгоритм.

Пожалуйста, буду очень благодарен.

На этой странице находится ответ на вопрос Получение алгоритма для обработки величин с реализацией на языке программирование?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.