Написать программу формирующую двумерный массив размером 4х4 и выводящую на экран максимальное количество элементов этого массива?

Информатика | 10 - 11 классы

Написать программу формирующую двумерный массив размером 4х4 и выводящую на экран максимальное количество элементов этого массива.

Ответить на вопрос
Ответы (1)
Searitey154 14 июл. 2020 г., 09:37:04

Видимо имеется ввиду выводящий максимальны элемент этого массива

В данном примере матрица формируется при помощи случайных чисел

program MatrixMax ;

Uses Crt ; type matrix = array[1.

4, 1.

4] of real ; var m : matrix ; max : real ;

{Порождение матрицы случайным образом}

procedure Auto ;

var i, j : integer ;

begin randomize ; for i : = 1 to 4 do begin for j : = 1 to 4 do begin m[i, j] : = 25 + random(21) ; end ; end ;

end ;

{Вывод матрицы на экран}

procedure PrintMatrix(mas : matrix ) ;

var j, k : integer ;

begin

for k : = 1 to 4 do begin for j : = 1 to 4 do begin write(mas[k, j] : 7 : 2) ; end ; writeln ; end ;

end ;

{Нахождение максимального элемента}

procedure Мax ;

var i, j : integer ;

begin max : = m[1, 1] for i : = 1 to 4 do begin for j : = 1 to 4 do begin if (max< ; m[i, j]) then max : = m[i, j] ; end ; end ;

end ;

begin Clrscr ; Auto ; PrintMatrix ; Max ; writeln ; writeln('Максимальный элемент матрицы : ', max) ;

end.

Pigalevacat 11 февр. 2020 г., 21:12:00 | 5 - 9 классы

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :А) выведите на экран количество и индексы отрицательных элементов массива?

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :

А) выведите на экран количество и индексы отрицательных элементов массива.

Б) выведите на экран количество, индексы и значения элементов массива, кратных шести.

Дополнительно :

Выведите на экран максимальный элемент массива и его индекс.

Выведите на экран количество элементов массива, равных 7.

Gjjkb 12 окт. 2020 г., 20:55:58 | 10 - 11 классы

Составить программу, формирующую массив b[2], каждый элемент которого является максимальным из соответствующих элементов массивов а[4] и с[4]?

Составить программу, формирующую массив b[2], каждый элемент которого является максимальным из соответствующих элементов массивов а[4] и с[4].

Ванига 13 июн. 2020 г., 19:28:24 | 5 - 9 классы

Дан двумерный массив?

Дан двумерный массив.

Вывести на экран все элементы S - го столбца массива.

Анюта444 7 июл. 2020 г., 02:38:28 | 10 - 11 классы

Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива?

Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива.

2001viola 24 янв. 2020 г., 05:33:36 | 5 - 9 классы

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25?

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.

Программа должна :

1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах ;

2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3)найти минимальное значение и максимальное значение элементов массива.

Buzkop 1 июл. 2020 г., 17:07:45 | 10 - 11 классы

Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент?

Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент.

Протестировать программу на массивах размерностью 8 и 10 элементов.

Fjmdfmnd 7 июл. 2020 г., 19:27:57 | 10 - 11 классы

Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы?

Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы.

Заразалина 31 дек. 2020 г., 10:12:24 | 5 - 9 классы

Пожалуйста, помогтме решить задачи на Pasсal?

Пожалуйста, помогтме решить задачи на Pasсal.

Во всех задачах массив состоит из 10 элементов и задаётся из интервала от 1 до 99.

1. Написать программу, которая выводит на экран все четные элементы массива и их количество.

2. Написать программу, которая выводит на экран все двузначные элементы массива и их количество.

3. Написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по индексу).

. Написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по значению).

5. Написать программу, которая выводит на экран количество элементов оканчивающихся на 5.

Elviraartisheva 5 июн. 2020 г., 06:39:40 | 1 - 4 классы

Дано два одномерных массива A и B?

Дано два одномерных массива A и B.

Заменить местами максимальные элементы массивов A и B.

Использовать процедуру нахождения максимального элемента массива.

Преобразовать эту программу для двумерного массива.

Inessa2016 21 окт. 2020 г., 17:09:44 | 10 - 11 классы

Напишите программу со вспомогательными алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и н?

Напишите программу со вспомогательными алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и на следующей строке номер последнего из его отрицательных элементов.

Перед вами страница с вопросом Написать программу формирующую двумерный массив размером 4х4 и выводящую на экран максимальное количество элементов этого массива?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.