Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы?

Информатика | 10 - 11 классы

Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы.

Ответить на вопрос
Ответы (1)
Kettigirl1995 7 июл. 2020 г., 19:28:00

Держи мой шаблон работы с матрицами, как раз пока только минимумы и максимумы

const handsfree = true ;

var a : array[1.

100, 1.

100] of real ; max, min : real ; i, j, m, n : integer ;

begin {ввод матрицы} if handsfree then begin n : = random(20) + 2 ; m : = random(20) + 2 ; end else begin write('n, m = ') ; readln(n, m) ; end ; writeln('Данные матрицы : ') ; for i : = 1 to m do begin for j : = 1 to n do if handsfree then begin a[i, j] : = random(100) - 50 ; write(a[i, j] : 4, ' ') end else read(a[i, j]) ; writeln ; end ; {минимумы и максимумы} max : = a[1, 1] ; min : = a[1, 1] ; for i : = 1 to m do for j : = 1 to n do begin if max < ; a[i, j] then max : = a[i, j] ; if min > ; a[i, j] then min : = a[i, j] ; end ; writeln('max = ', max) ; writeln('min = ', min) ;

end.

Nshinshina 29 июн. 2020 г., 05:29:08 | 10 - 11 классы

Определить минимальный элемент двумерного массива?

Определить минимальный элемент двумерного массива.

Напечатать номер строки, содержащей максимальное число минимальных элементов, если такие имеются ; ).

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Froburl 14 мар. 2020 г., 09:31:52 | 10 - 11 классы

Написать программу поиска значения максимального элемента массива?

Написать программу поиска значения максимального элемента массива.

Vikik123 2 апр. 2020 г., 08:19:27 | 10 - 11 классы

Напишите программу поиска минимального и максимального элементов матрицы?

Напишите программу поиска минимального и максимального элементов матрицы.

Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль).

Fiksator3780 11 дек. 2020 г., 11:00:21 | 10 - 11 классы

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов?

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов.

Известно, что в массиве есть хотя бы один нечетный элемент.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

Elviraartisheva 5 июн. 2020 г., 06:39:40 | 1 - 4 классы

Дано два одномерных массива A и B?

Дано два одномерных массива A и B.

Заменить местами максимальные элементы массивов A и B.

Использовать процедуру нахождения максимального элемента массива.

Преобразовать эту программу для двумерного массива.

SpiderMan1997 3 авг. 2020 г., 10:04:59 | 10 - 11 классы

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве?

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве.

Pasha1417 26 апр. 2020 г., 04:55:31 | 10 - 11 классы

Помогите c С#?

Помогите c С#!

На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.

2002ru 19 сент. 2020 г., 12:17:56 | 10 - 11 классы

В двумерном массиве 10х15 найти разность между максимальным и минимальным элементами массива, заданными случайным образом на интервале [ - 50 ; 50])))) Пожалуйста?

В двумерном массиве 10х15 найти разность между максимальным и минимальным элементами массива, заданными случайным образом на интервале [ - 50 ; 50])))) Пожалуйста!

))).

Если вам необходимо получить ответ на вопрос Алгоритм поиска максимального и минимального значений элементов двумерного массива, пример программы?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.