Напишите программу со вспомогательными алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и н?

Информатика | 10 - 11 классы

Напишите программу со вспомогательными алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и на следующей строке номер последнего из его отрицательных элементов.

Ответить на вопрос
Ответы (1)
Netel 21 окт. 2020 г., 17:09:48

Ну, значит, как - то так :

program arrays ;

type myArr = array of integer ;

var arr : myArr ; neg : integer ; i, n : integer ;

begin write('Введите размер массива : ') ; readln(n) ; if n> ; 50 then n : = 50 ; setLength(arr, n) ; randomize ; neg : = 0 ; for i : = 0 to n - 1 do begin arr[i] : = random(200) - 100 ; if arr[i]< ; 0 then neg : = arr[i] ; write(arr[i], ' ') ; end ; writeln ; writeln ('Последний отрицательный элемент массива : ', neg) ;

end.

Djambaev 4 июн. 2020 г., 06:04:48 | 5 - 9 классы

Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива таким образом, что производится перестановка 6 и 16 э?

Составьте программу, которая формирует массив из 20 случайных чисел, и выводит на экран вначале исходные, а затем преобразованные элементы массива таким образом, что производится перестановка 6 и 16 элементов массива.

Kaima46 3 июл. 2020 г., 01:14:36 | 10 - 11 классы

Помогите пожалуйста составить программу?

Помогите пожалуйста составить программу.

Создайте двумерный массив вещественных чисел, имеющих 10 строк и 15 столбцов, выведите его на экран.

Затем разделите каждый элемент массива на среднее арифметическое значение элементов строки, в которой они расположены и результат выведите на экран.

Ephemeral 14 июл. 2020 г., 02:29:23 | 5 - 9 классы

Составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит на экран в строку данный массив?

Составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов, формирует и выводит на экран в строку данный массив.

Найти сумму неположительных элементов массива, количество элементов кратных 3, произведение элементов, стоящих на четных местах.

KristinaRaccon 14 июл. 2020 г., 09:37:03 | 10 - 11 классы

Написать программу формирующую двумерный массив размером 4х4 и выводящую на экран максимальное количество элементов этого массива?

Написать программу формирующую двумерный массив размером 4х4 и выводящую на экран максимальное количество элементов этого массива.

Cheburek98 22 дек. 2020 г., 11:54:32 | 5 - 9 классы

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент?

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент.

Протестировать программу на массивах размерностью 5 и 10 элементов.

Zhenk2011 20 июн. 2020 г., 10:41:16 | 10 - 11 классы

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел?

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел.

( На языке Паскаль С + + ).

Botya1974 10 мая 2020 г., 02:40:54 | 5 - 9 классы

Напишите на ^ Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива?

Напишите на ^ Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.

Buzkop 1 июл. 2020 г., 17:07:45 | 10 - 11 классы

Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент?

Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент.

Протестировать программу на массивах размерностью 8 и 10 элементов.

Sunstar 25 июн. 2020 г., 03:44:52 | 5 - 9 классы

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран?

Написать программу, которая вводит с клавиатуры не пустой массив целых чисел, печатает его, затем находит максимальный и минимальный элемент массива, выводит их на экран.

199820031 30 апр. 2020 г., 05:52:55 | 10 - 11 классы

Запросить и ввести количество членов линейного массива не более 50 затем сам массив действительных чисел вывести получившийся массив и вывести номера элементов равных 7, 5?

Запросить и ввести количество членов линейного массива не более 50 затем сам массив действительных чисел вывести получившийся массив и вывести номера элементов равных 7, 5.

На этой странице находится ответ на вопрос Напишите программу со вспомогательными алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и н?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.