Помогите люди))?

Информатика | 10 - 11 классы

Помогите люди)).

Дана квадратная целочисленная матрица размера 4х4.

Заменить нулями элементы матрицы, лежащие на главной диагонали.

В bordland paskal .

Задача на двумерный массив.

Ответить на вопрос
Ответы (1)
Kапyчиnkа221 19 мар. 2020 г., 23:23:18

Const n = 4 ;

var a : array[1.

N, 1.

N] of integer ; i, j : integer ;

begin for i : = 1 to n * n do a[i mod n + 1, (i - 1) div n + 1] : = random(10) ; for i : = 1 to n do begin writeln() ; for j : = 1 to n do begin if i = j then a[i, j] : = 0 ; write(a[i, j] : 3) ; end ; end ;

end.

Ila2904 29 сент. 2020 г., 23:03:04 | 10 - 11 классы

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей?

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей.

Vladaa50 28 июн. 2020 г., 14:37:19 | 5 - 9 классы

Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10, 99], а затем записывает нули во все элементы выше главной диагонали?

Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10, 99], а затем записывает нули во все элементы выше главной диагонали.

Алгоритм не должен изменяться при изменении размеров матрицы.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Yarima 12 окт. 2020 г., 14:59:23 | 10 - 11 классы

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal?

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal.

АНДРИЕВСКИЙ 27 июл. 2020 г., 08:57:22 | 1 - 4 классы

Дана матрица Z(3?

Дана матрица Z(3.

3) заменить все на нули все её элементы, расположенные на главной диагонали.

Преобразованную и исходную матрицу вывести по строкам.

Zajchikova1986 2 апр. 2020 г., 15:05:57 | 10 - 11 классы

Дана квадратная матрица порядка N?

Дана квадратная матрица порядка N.

Найти произведение элементов побочных диагонали квадратной матрицы.

KarinaAksenova 16 мар. 2020 г., 23:26:59 | 10 - 11 классы

Написать программу на С + + ?

Написать программу на С + + .

Дана целочисленная квадратная матрица произвольной размерности.

Сформировать одномерный массив, в который поместить элементы двумерной матрицы, находящиеся над побочной диагонали ; упорядочить их по возрастанию и найти их среднее арифметическое.

IvanWein 14 сент. 2020 г., 17:25:44 | 10 - 11 классы

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями?

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями.

Белкария 31 июл. 2020 г., 02:57:19 | 10 - 11 классы

Дана целочисленная матрица размера 5 на 5?

Дана целочисленная матрица размера 5 на 5.

Найти минимальный элемент.

Лыоадыо 13 сент. 2020 г., 02:44:29 | 5 - 9 классы

С + + ?

С + + .

Определить максимальный элемент матрицы на главной диагонали и сумму элементов этой диагонали.

Размер матрицы вводить с клавиатуры, элементы, а также результат, разместить в памяти динамически.

Вы зашли на страницу вопроса Помогите люди))?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.