7. Ввести вещественную матрицу размером m * n?

Информатика | 10 - 11 классы

7. Ввести вещественную матрицу размером m * n.

Вывести индексы тех строк, в которых есть хотя бы одно значение, дробная часть которого меньше 0.

55, или сообщение об отсутствии в матрице таких значений.

8. Ввести квадратную матрицу порядка n.

Вычислить произведение элементов, расположенных на главной диагонали.

Сформировать одномерный массив из элементов исходной матрицы, расположенных ниже главной диагонали и больших произведения ее элементов.

Вывести полученный массив или сообщение об отсутствии таких элементов.

9. Дан одномерный целочисленный массив размерностью N.

Сформировать новый массив из элементов исходного, расположенных до первого отрицательного элемента и большего первого элемента исходного массива.

Если такие элементы отсутствуют, то выдать об этом сообщение.

Ответить на вопрос
Ответы (1)
Мэри56 19 мар. 2020 г., 10:10:12

Program Drob_0_55 ;

uses Crt ;

const m = 5 ; n = 6 ;

type Mat = array[1.

M, 1.

N] of real ;

var A : Mat ; i, j : integer ; frc : real ; flag : boolean ;

begin

ClrScr ; Randomize ; {Датчик СЧ} for i : = 1 to m do {Цикл ввода и вывода массива} begin for j : = 1 to n do begin A[i, j] : = (10 + random(70)) / 100 ; Write (A[i, j] : 6 : 2) ; end ; WriteLn ; end ; for i : = 1 to m do {Поиск} begin flag : = false ; for j : = 1 to n do begin frc : = frac(A[i, j]) ; if frc> ; 0.

55 then flag : = true ; end ; if flag then Writeln('‘Строка : ', i) ; end ; if flag = false then WriteLn('Не найдено!

') ;

ReadLn ; {Ожидание нажатия ENTER}

end.

F.

Ila2904 29 сент. 2020 г., 23:03:04 | 10 - 11 классы

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей?

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей.

Polinadudiy 4 июн. 2020 г., 02:46:07 | 10 - 11 классы

Дана вещественная квадратная матрица А, размерностью n * n?

Дана вещественная квадратная матрица А, размерностью n * n.

Найти сумму элементов матрицы, расположенных под главной диагональю.

АНДРИЕВСКИЙ 27 июл. 2020 г., 08:57:22 | 1 - 4 классы

Дана матрица Z(3?

Дана матрица Z(3.

3) заменить все на нули все её элементы, расположенные на главной диагонали.

Преобразованную и исходную матрицу вывести по строкам.

Anna19681 25 авг. 2020 г., 06:14:42 | 5 - 9 классы

Дана матрица С[Н, М]?

Дана матрица С[Н, М].

Сформировать массив В, элементами которого являются значения элементов тех строк исходного массива, сумма которых положительна.

Коля2004 21 мар. 2020 г., 13:08:48 | 1 - 4 классы

Дана матрица А(3, 3)?

Дана матрица А(3, 3).

В строках с отрицательным элементом на главной диагонали найти суммы всех элементов.

Вывести номера строк, суммы, а так же матрицу А по строкам.

Паскаль.

Angelinaaleksan 7 мая 2020 г., 22:38:13 | 10 - 11 классы

Дана вещественная квадратная матрица А порядка n?

Дана вещественная квадратная матрица А порядка n.

Найти среднее арифметическое среди положительных элементов матрицы, находящихся на главной и побочной диагоналях.

Выдать сообщение, если таких элементов нет.

KarinaAksenova 16 мар. 2020 г., 23:26:59 | 10 - 11 классы

Написать программу на С + + ?

Написать программу на С + + .

Дана целочисленная квадратная матрица произвольной размерности.

Сформировать одномерный массив, в который поместить элементы двумерной матрицы, находящиеся над побочной диагонали ; упорядочить их по возрастанию и найти их среднее арифметическое.

Losemyselft1 22 окт. 2020 г., 23:13:40 | 10 - 11 классы

Сформировать одномерный массив из 20 элементов (значения элементов задаются пользователем)?

Сформировать одномерный массив из 20 элементов (значения элементов задаются пользователем).

Увеличить каждый элемент на 1.

Вывести на экран исходный и итоговый массивы.

Gnusarkovru 10 мая 2020 г., 21:05:37 | 10 - 11 классы

Дана квадратная матрица А порядка N, состоящая из натуральных чисел?

Дана квадратная матрица А порядка N, состоящая из натуральных чисел.

Если сумма индексов каких - либо двух элементов матрицы, расположенных ниже главной диагонали, равна минимальному элементу для всей матрицы, то вывести на экран сообщение "Да", иначе - сообщение "Нет" Помогите пожалуйста(( Язык С + +.

Умникус2015 21 сент. 2020 г., 13:21:12 | 10 - 11 классы

Заданы матрица порядка n и число k?

Заданы матрица порядка n и число k.

Разделить элементы k - й строки на диагональный элемент, расположенный в этой строке.

Исходную и полученную матрицы вывести на экран.

На этой странице вы найдете ответ на вопрос 7. Ввести вещественную матрицу размером m * n?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.