Дано трехзначное число?

Информатика | 10 - 11 классы

Дано трехзначное число.

Вывести «Yes», если его цифры образуют возрастающую или убывающую последовательность.

В противном случае вывести «No».

Ответить на вопрос
Ответы (1)
Glebochkakozlo 27 мар. 2020 г., 06:45:05

Const N = 10 ;

var i, b, s : integer ; a : string ;

begin readln(b) ; a : = inttostr(b) ; for i : = 1 to length(a) do if (strtoint(a[i]) > ; s) then s : = strtoint(a[i]) else s : = 10 ; if (s = 10) then writeln('No') else writeln('Yes') ;

end.

Удачи = ).

Nizami2000 29 янв. 2020 г., 23:46:35 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Вывести порядковый номер его минимальной цифры.

Паскаль.

Vikusya16 18 мая 2020 г., 22:28:20 | 10 - 11 классы

3. Дано целое трехзначное число А?

3. Дано целое трехзначное число А.

Вывести цифры этого числа на экран в столбик.

Паскаль.

22341567 10 февр. 2020 г., 02:10:35 | 5 - 9 классы

Составить программу, печатающую значение 1, если указанное высказывание является истинным, и 0 в противном случае : цифры данного двузначного числа N образуют строго возрастающую последовательность?

Составить программу, печатающую значение 1, если указанное высказывание является истинным, и 0 в противном случае : цифры данного двузначного числа N образуют строго возрастающую последовательность.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Nonchik 24 февр. 2020 г., 06:49:28 | 5 - 9 классы

Даны три числа, если хотя бы одно из чисел больше 0, то вывести True , в противном случае False?

Даны три числа, если хотя бы одно из чисел больше 0, то вывести True , в противном случае False.

Makcimys12395 28 окт. 2020 г., 15:23:13 | 5 - 9 классы

Дана последовательность целых чисел, оканчивающаяся числом 100?

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77.

Если такое число есть, то вывести «Yes».

В противном случае вывести «No».

Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

Помогитесуровнением 26 мар. 2020 г., 13:24:02 | 10 - 11 классы

Дано вещественное число?

Дано вещественное число.

Вывести на экран его абсольтную величину , если число отрицательное, или дробную часть в противном случае.

Vipexb 20 янв. 2020 г., 03:20:33 | 5 - 9 классы

Дана последовательность целых чисел, оканчивающаяся числом 100?

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77.

Если такое число есть, то вывести «Yes».

В противном случае вывести «No».

Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

( в ПАСКАЛЕ).

EmmaMiller 6 авг. 2020 г., 21:40:23 | 5 - 9 классы

Решите пожалуйста Абрамян М Э 1000 задачь на С + + Series22 Дано целое число N(больше 0) и набор на N вещественных чисел Если данный набор образует убываюшию последовательность то вывести 0 ; в против?

Решите пожалуйста Абрамян М Э 1000 задачь на С + + Series22 Дано целое число N(больше 0) и набор на N вещественных чисел Если данный набор образует убываюшию последовательность то вывести 0 ; в противном случае вывести номер первого числа нарушаюшую закономерность.

ТаткаТаточка 3 мая 2020 г., 01:57:08 | 5 - 9 классы

С клавиатуры вводится 5 - значное число?

С клавиатуры вводится 5 - значное число.

Если первая и последняя цифры этого числа четные, вывести на экран "четные", в противном случае вывести "нечетные" помогите пж.

На этой странице находится ответ на вопрос Дано трехзначное число?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.