Помогите, пожалуйста?

Информатика | 5 - 9 классы

Помогите, пожалуйста!

Информатика, 10 класс, Паскаль 1)Написать программу.

Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : сумма десятков первого и второго числа и сумма единиц первого и второго числа.

2)Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : произведение десятков первого числа и единиц второго числа ; произведение единиц первого числа и десятков второго.

3)Вводятся два двухзначных целых числа.

Подсчитать и вывести два числа : произведение десятков первого числа и единиц второго числа ; сумма единиц первого числа и десятков второго числа.

Ответить на вопрос
Ответы (1)
Рита00 16 июн. 2020 г., 01:33:33

Первая программа.

Program d_and_e ;

Var a, b, sum_d, sum_e : integer ;

Begin WriteLn('введите первое число : ') ; ReadLn(a) ; WriteLn('введите второеое число : ') ; ReadLn(b) ; sum_d : = (a div 10) + (b div 10) ; sum_e : = (a mod 10) + (b mod 10) ; WriteLn('сумма десятков чисел : ', sum_d) ; WriteLn('сумма единиц чисел : ', sum_e) ;

end.

Вторая программа.

Program d_and_e ;

Var a, b, mult_d1_e2, mult_e1_d2 : integer ;

Begin WriteLn('введите первое число : ') ; ReadLn(a) ; WriteLn('введите второе число : ') ; ReadLn(b) ; mult_d1_e2 : = (a div 10) * (b mod 10) ; mult_e1_d2 : = (a mod 10) * (b div 10) ; WriteLn('произведение десятков 1 - го и единиц 2 - го числа : ', mult_d1_e2) ; WriteLn('произведение единиц 1 - го и десятков 2 - го числа : ', mult_e1_d2) ;

end.

Третья программа.

Program d_and_e ;

Var a, b, mult_d1_e2, sum_e1_d2 : integer ;

Begin WriteLn('введите первое число : ') ; ReadLn(a) ; WriteLn('введите второе число : ') ; ReadLn(b) ; mult_d1_e2 : = (a div 10) * (b mod 10) ; sum_e1_d2 : = (a mod 10) + (b div 10) ; WriteLn('произведение десятков 1 - го и единиц 2 - го числа : ', mult_d1_e2) ; WriteLn('сумма единиц 1 - го и десятков 2 - го числа : ', sum_e1_d2) ;

end.

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

Danhek32 14 сент. 2020 г., 13:24:15 | 10 - 11 классы

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal)?

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal).

Kate777123 17 янв. 2020 г., 14:58:16 | 5 - 9 классы

Даны два целых числа?

Даны два целых числа.

Программа должна вывести число 1, если первое число больше второго, число 2, если второе больше первого или число 0, если они равны.

Ввод 4, 5 Вывод 2.

Maribamariba031 8 нояб. 2020 г., 14:30:12 | 5 - 9 классы

Дано целое положительное четырехзначное число?

Дано целое положительное четырехзначное число.

Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует первой цифре заданного числа, а число единиц - последней.

Например : 3234 = > ; 34.

Marinakhoroshi 26 февр. 2020 г., 03:52:15 | 10 - 11 классы

Задача в С + + ?

Задача в С + + .

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы цифре сотен числа а, увеличенной на цифру единиц числа а, число десятков в b обнулить, а вместо единиц поставить число десятков от числа а.

Аленький 16 сент. 2020 г., 03:07:40 | 10 - 11 классы

Помогите, пожалуйста, написать программы на Паскале?

Помогите, пожалуйста, написать программы на Паскале.

Задачи : 1.

Сгенерировать случайное число, вывести на экран это число, а также сумму и произведение его цифр.

2. Вводятся целые числа до первого числа, которое меньше двух.

Определить, сколько простых чисел было введено.

Saiaanowa 4 окт. 2020 г., 13:20:39 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найдите число десятков в нем.

Входные данные Вводится двухзначное число.

Выходные данные Выведите ответ на задачу.

Mahich500 18 нояб. 2020 г., 23:55:59 | 5 - 9 классы

Найти сумму всех элементов массива А у которых число десятков (вторая с конца цифра десятичной записи) больше, чем число единиц?

Найти сумму всех элементов массива А у которых число десятков (вторая с конца цифра десятичной записи) больше, чем число единиц.

Nirah35 9 нояб. 2020 г., 00:10:09 | 5 - 9 классы

Напишите пожалуйста программы на языке Паскаль?

Напишите пожалуйста программы на языке Паскаль!

Очень нужно!

Первая программа : ввод и вывод рандомного числа))) вторая программа : надо вывести самое наименьшее число(на основе первой)) пожалуйста!

Полюсечка1 20 дек. 2020 г., 20:28:11 | 5 - 9 классы

Дано натуральное трехзначное число a?

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы сумме цифр числа единиц и десятков числа а, десятков в b равно увеличенному на 2 числу десятков в числе а, а вместо единиц поставить цифру 0.

C + +.

Вы зашли на страницу вопроса Помогите, пожалуйста?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.