Составить программу для вычисления длины n - мерного вещественного вектора Х = (Х1, Х2, ?

Информатика | 10 - 11 классы

Составить программу для вычисления длины n - мерного вещественного вектора Х = (Х1, Х2, .

, Xn) по формуле L = sqrt(((X1) ^ 2) + ((X2) ^ 2) + .

+ ((Xn) ^ 2)).

Ответить на вопрос
Ответы (1)
Лол103д 13 апр. 2020 г., 21:45:25

Const nm = 50 ; {максимальная размерность вектора}

var i, n : integer ; x : array[1.

Nm] of real ; s : real ;

begin Write('Введите размерность вектора n - > ; ') ; Readln(n) ; Write('Вводите координаты вектора через пробел ') ; s : = 0 ; for i : = 1 to n do begin Read(x[i]) ; s : = s + sqr(x[i]) end ; Writeln('Длина вектора равна ', sqrt(s) : 0 : 4)

end.

Тестовое решение :

Введите размерность вектора n - > ; 7

Вводите координаты вектора через пробел - 3.

54 0.

532 2.

6 12 - 3 0 1.

47

Длина вектора равна 13.

2188.

Kovgosha 31 мая 2020 г., 18:10:47 | 10 - 11 классы

Функция задана формулой y = (x - 1) составить программу для ее вычисления?

Функция задана формулой y = (x - 1) составить программу для ее вычисления.

АВС16 27 апр. 2020 г., 08:18:37 | 10 - 11 классы

1. Напишите программу вычисления расстояния между двумя точками плоскости?

1. Напишите программу вычисления расстояния между двумя точками плоскости.

2. Напишите программу вычисления площади боковой поверхности куба.

3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты.

4. Напишите программу вычисления суммы модулей трех трех вещественных чисел.

Anst22 23 сент. 2020 г., 10:55:12 | 10 - 11 классы

Составить программу вычислить значение выражения по формуле (все переменные принимают вещественные значения) : Z = корень 1 - sina?

Составить программу вычислить значение выражения по формуле (все переменные принимают вещественные значения) : Z = корень 1 - sina.

Shestakova1 22 янв. 2020 г., 16:41:21 | 10 - 11 классы

Составить программу для вычисления величины S по легкой формулеВНИМАНИЕ?

Составить программу для вычисления величины S по легкой формуле

ВНИМАНИЕ!

Помогите дам 40 баллов!

Ishbuildina 16 июл. 2020 г., 18:01:02 | 10 - 11 классы

Составить программу вычисления длин медиан треугольника, у которой длины сторон a, b, c?

Составить программу вычисления длин медиан треугольника, у которой длины сторон a, b, c.

Масик111 18 авг. 2020 г., 01:56:18 | 10 - 11 классы

Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1?

Составить программу вычисления произведения не нулевых элементов массива (а) вещественных чисел [1.

5] . решите пожалуйста.

Лисичкаа 6 февр. 2020 г., 11:19:02 | 5 - 9 классы

Помогите составить программу и блок - схему к задаче : вычисление площади треугольника по формуле Герона?

Помогите составить программу и блок - схему к задаче : вычисление площади треугольника по формуле Герона.

LikeLiver 29 июн. 2020 г., 17:52:20 | 5 - 9 классы

Составить программу вычисления длины окружности и площади круга по заданному радиусу?

Составить программу вычисления длины окружности и площади круга по заданному радиусу.

Yuy2 12 мая 2020 г., 12:31:01 | 10 - 11 классы

Составить программу для вычисления длины диагонали прямоугольника со сторонами a, b?

Составить программу для вычисления длины диагонали прямоугольника со сторонами a, b.

Chypi 5 янв. 2020 г., 10:49:42 | 10 - 11 классы

Составить программу для вычисления площади круга и длины окружности?

Составить программу для вычисления площади круга и длины окружности.

B C + +.

На этой странице сайта размещен вопрос Составить программу для вычисления длины n - мерного вещественного вектора Х = (Х1, Х2, ? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.