Написать программу, которая бы по введенному номеру единицы измерения (1 - килограмм, 2 - миллиграмм, 3 - грамм, 4 - тонна, 5 - центнер) и массе M выдавала соответствующее значение массы в килограммах?

Информатика | 10 - 11 классы

Написать программу, которая бы по введенному номеру единицы измерения (1 - килограмм, 2 - миллиграмм, 3 - грамм, 4 - тонна, 5 - центнер) и массе M выдавала соответствующее значение массы в килограммах.

Выполнить в Паскале.

Ответить на вопрос
Ответы (1)
Anna2428 5 мар. 2024 г., 05:10:15

Program massa ; var m, a : real ;   ;   ;   ; begin  ;   ;   ;   ; writeln('Введите массу.

') ;   ;   ;   ;   ; readln(m) ;   ;   ;   ;   ; writeln('Введите единицу измерения массы.

1 - килограмм, 2 - миллиграмм, 3 - грамм, 4 - тонна, 5 - центнер.

') ;   ;   ;   ;   ; readln(a) ;   ;   ;   ;   ; writeln('Введённое вами значение равно ') ;   ;   ;   ;   ; if a = 1 then write(m, ' килограмм.

') ;   ;   ;   ;   ; if a = 2 then write(m / 1000000, ' килограмм.

') ;   ;   ;   ;   ; if a = 3 then write(m / 1000, ' килограмм.

') ;   ;   ;   ;   ; if a = 4 then write(m * 1000, ' килограмм.

') ;   ;   ;   ;   ; if a = 5 then write(m * 100, ' килограмм.

') ;   ;   ;   ; end.

Меее, немного с окончаниями напортачила, но если надо, то можно просто до кг сократить и всё будет ок.

ДдддАааа 2 февр. 2024 г., 01:57:06 | студенческий

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры?

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры.

Если да то, выполните деление, если нет, то выведите на экран сообщение что нельзя поделит без остатка.

Помогите пж!

Саша1322 25 мар. 2024 г., 22:31:52 | 10 - 11 классы

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив?

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив.

Для определения максимального элемента в строке использовать function , а для ввода и вывода массивов - procedure.

OpchikPolininPopchik 25 февр. 2024 г., 10:35:10 | 10 - 11 классы

Срочно?

Срочно!

Третья пересдача, помогите написать программу для этой задачи, пожалуйста!

Язык C + +

Задан числовой массив А[m][n].

Составить программу поиска элемента массива, который является наибольшим из минимальных по строкам​.

Муштариюону 18 апр. 2024 г., 22:06:30 | 5 - 9 классы

Составить программу, которая создает одномерный целочисленный массив, состоящий из 15 элементов, инициализирует его и выводит на печать?

Составить программу, которая создает одномерный целочисленный массив, состоящий из 15 элементов, инициализирует его и выводит на печать.

Аружан0611 22 мар. 2024 г., 22:54:27 | 5 - 9 классы

Напишите пожалуйста программу в паскале : Вводится 15 чисел?

Напишите пожалуйста программу в паскале : Вводится 15 чисел.

Найти сумму чисел, введенных с пятого по десятое.

Лерок56 11 февр. 2024 г., 12:07:39 | 1 - 4 классы

Помогите решить, 4 заданиеНаписать программу в паскале для решения уравнения​?

Помогите решить, 4 задание

Написать программу в паскале для решения уравнения​.

Артикль 5 апр. 2024 г., 00:14:30 | 10 - 11 классы

Нужно написать программу на паскале?

Нужно написать программу на паскале.

Nastya5053443 22 февр. 2024 г., 22:39:23 | 10 - 11 классы

Паскаль 8 класснаписать программу, которая выводит на экран все четные числа, делящиеся на 4 нацело, лежащие в диапазоне от 64 до 247?

Паскаль 8 класс

написать программу, которая выводит на экран все четные числа, делящиеся на 4 нацело, лежащие в диапазоне от 64 до 247.

АружанАлихан 13 апр. 2024 г., 14:32:40 | 5 - 9 классы

Нужно написать программу в паскалеВозвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число R?

Нужно написать программу в паскале

Возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число R.

Lisa12345678900 22 янв. 2024 г., 23:03:01 | 10 - 11 классы

PYTHON написать программуНаписать программу, которая запрашивает у пользователя номер месяца и выводит соответствующее ему время года?

PYTHON написать программу

Написать программу, которая запрашивает у пользователя номер месяца и выводит соответствующее ему время года.

Вы перешли к вопросу Написать программу, которая бы по введенному номеру единицы измерения (1 - килограмм, 2 - миллиграмм, 3 - грамм, 4 - тонна, 5 - центнер) и массе M выдавала соответствующее значение массы в килограммах?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.