Дан массив А из N целочисленных элементов?

Информатика | 5 - 9 классы

Дан массив А из N целочисленных элементов.

1)Заполнить массив А целыми числами в интервале[1, 100] и вывести на экран.

Найти максимальный четный элемент и вывести его на экран.

2)Заполнить массив А целыми числами в интервале[1, 100] и вывести на экран.

Найти второй минимальный нечетный элемент и вывести его на экран.

Ответить на вопрос
Ответы (1)
Nikita2002n 16 апр. 2024 г., 07:19:56

1) uses crt ;

var i, n, s, mx : integer ; a : array[1.

1000] of integer ;

begin

randomize() ;

mx : = - 100 ;

for i : = 1 to 10 do begin

a[i] : = random(100) + 1 ;

write(a[i], ' ') ;

if (a[i] mod 2 = 0) and (mx < ; a[i])then mx : = a[i] ;

end ;

writeln('') ;

writeln(mx) ;

end.

2)

uses crt ;

var i, n, s, mn1, mn2 : integer ; a : array[1.

1000] of integer ;

begin

randomize() ;

mn1 : = 101 ;

mn2 : = 101 ;

for i : = 1 to 10 do begin

a[i] : = random(100) + 1 ;

write(a[i], ' ') ;

if (a[i] mod 2 = 1) and (mn1 > ; a[i])then begin

mn2 : = mn1 ;

mn1 : = a[i]

end ;

end ;

writeln('') ;

writeln(mn2) ;

end.

Анжелика268 18 февр. 2024 г., 07:10:49 | 5 - 9 классы

Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?

Дан одномерный массив B из 20 целых чисел

(числа вводятся по формуле (i + 2 * (i - 1)), вывести

на экран массив в строку через пробел, найти и

вывести максимальный элемент массива.

Maria535 7 февр. 2024 г., 22:12:01 | 5 - 9 классы

Дано число, удвоить его в 3 раза если оно кратно 17?

Дано число, удвоить его в 3 раза если оно кратно 17.

В противном случае уменьшить на 4.

Вывести ответ на экран.

В pascal abc.

Милана632 14 мар. 2024 г., 23:48:12 | 5 - 9 классы

Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым?

Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым.

Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем.

Pascal ABC.

Русский242 27 янв. 2024 г., 11:28:29 | студенческий

M меньше n, n и m натуральные числа?

M меньше n, n и m натуральные числа.

Вывести на экран числа от m до n которые не являются простыми.

Nsysoeva29 30 янв. 2024 г., 21:04:14 | 5 - 9 классы

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0?

С клавиатуры вводится последовательность натуральных чисел, оканчивающихся числом 0.

Количество чисел в последовательности неизвестно.

Программа должна вывести на экран четные числа из этой последовательности, которые не меньше 50.

Annatitova12345 3 апр. 2024 г., 09:43:12 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти и вывести элементы этого массива, принадлежащие диапазону от А до В (А и В ввести с клавиатуры).

Язык программирования pascal.

Anzhelika233 5 февр. 2024 г., 18:58:30 | 5 - 9 классы

Вывести на экран n первых чисел Фибоначчи python​?

Вывести на экран n первых чисел Фибоначчи python​.

Ateist1958 21 янв. 2024 г., 23:13:14 | 10 - 11 классы

Помогите пожалуйста Python Найти количество одинаковых элементов списка X и вывести их на экран?

Помогите пожалуйста Python Найти количество одинаковых элементов списка X и вывести их на экран.

Tang17 27 янв. 2024 г., 05:47:25 | студенческий

Заполнить матрицу 10х10 так, чтобы элементы главной диагонали и все, что над ней, были = 1, а остальные - 0?

Заполнить матрицу 10х10 так, чтобы элементы главной диагонали и все, что над ней, были = 1, а остальные - 0.

Вывести матрицу на экран.

Паскаль.

AllenRocket 20 февр. 2024 г., 03:13:47 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста.

Напишите программу, которая заполняет массив из 10 элементов случайными числами в диапазоне [0, 10], выводит его на экран, а затем выводит на экран квадраты всех элементов массива

пример :

массив : 5 6 2 3 1 4 8 7

квадраты : 25 36 4 9 1 16 6449.

Если вам необходимо получить ответ на вопрос Дан массив А из N целочисленных элементов?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.