Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?

Информатика | 5 - 9 классы

Дан одномерный массив B из 20 целых чисел

(числа вводятся по формуле (i + 2 * (i - 1)), вывести

на экран массив в строку через пробел, найти и

вывести максимальный элемент массива.

Ответить на вопрос
Ответы (1)
Vdavidenko 18 февр. 2024 г., 07:10:53

Ответ :

Лучше перепроверь в паскале, то ли делает программа, что требуется в задании.

Program zadacha ;

var B : array[1.

10000] of integer ;

i, max : integer ;

begin

B[1] : = 1 + 2 * (1 - 1) ;

max : = B[1] ;

for i : = 2 to 20 do

B[i] : = i + 2 * (i - 1) ;

if B[i]> ; max then

max : = B[i] ;

for i : = 1 to 20 do

write(' ', B[i]) ;

writeln(' ') ;

writeln('наибольший элемент - ', max) ;

end.

Объяснение :

Светкаsveta 27 янв. 2024 г., 11:12:57 | 10 - 11 классы

Язык Си заполнить массив из 10 элементов случайными числами в интервале [ - 10 ; 10] и выполнить инверсию отдельно для 1 - й и 2 - й половин массива?

Язык Си заполнить массив из 10 элементов случайными числами в интервале [ - 10 ; 10] и выполнить инверсию отдельно для 1 - й и 2 - й половин массива.

Dashulyagolubets 3 янв. 2024 г., 02:31:50 | 5 - 9 классы

В одномерном массиве все отрицательные элементы переместить в начало массива, а остальные – в конец с сохранением порядка следования?

В одномерном массиве все отрицательные элементы переместить в начало массива, а остальные – в конец с сохранением порядка следования.

Дополнительный массив заводить не разрешается.

​.

Гргргр 7 янв. 2024 г., 23:19:23 | 5 - 9 классы

Даны два целых числа A и B (A < ; B)?

Даны два целых числа A и B (A < ; B).

Найти сумму квадратов всех целых чисел от A до B включительно.

В питоне.

Sharkovka05 1 февр. 2024 г., 22:51:40 | студенческий

Программа на С + +Не сталкивался и с этимПросьба большая помочьСоздать целочисленный массив типа short int размером n?

Программа на С + +

Не сталкивался и с этим

Просьба большая помочь

Создать целочисленный массив типа short int размером n.

Элементы массива инициализируются по следующему алгоритму :

1) число А вводится с консоли ;

2) используя битовые операции, сделать в нем так, чтобы 11 бит был заменён значением 5 - го бита, а остальные сохранили свои значения.

3) присвоить преобразованное число А текшему элементу массива.

Инициализированный массив вывести на печать и найти в нём элементы, у которых старшая четвёрка бит имеет все единицы.

Aidanai250 28 февр. 2024 г., 21:14:24 | 5 - 9 классы

Паскаль программа, срочно?

Паскаль программа, срочно!

Кароче надо с randomize вывести 10 чисел от 1 до 100​.

Школота15лохатрон 1 мар. 2024 г., 07:02:11 | 5 - 9 классы

Вывести нечетные числа из диапазона [a ; b], где a b м?

Вывести нечетные числа из диапазона [a ; b], где a b м.

Б. как четными так и нечетными, а также отрицательными НО обязательно a.

Dmitrievvanya 4 мар. 2024 г., 04:10:55 | 10 - 11 классы

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ?

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ!

Дано неотрицательное число N - количество элементов массива (N< ; = 100)

Заполнить массив из N элементов первыми натуральными трехзначными числами, произведение цифр которых есть трехзначное число.

ДашаВова 30 янв. 2024 г., 05:19:22 | 5 - 9 классы

Даны три числа a, b, с?

Даны три числа a, b, с.

Найти их среднее арифметическое(сумму чисел разделить на их количество).

С клавиатуры вводится число a, количество килобайт.

Переведите это число в байты, биты и мегабайты и выведите значения на экран.

​.

Саша1322 25 мар. 2024 г., 22:31:52 | 10 - 11 классы

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив?

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив.

Для определения максимального элемента в строке использовать function , а для ввода и вывода массивов - procedure.

Vsail 28 февр. 2024 г., 14:22:32 | студенческий

На вход подается два числа n и X, необходимо посчитать такую сумму X ^ 1 + X ^ 2 + X ^ 3 + ?

На вход подается два числа n и X, необходимо посчитать такую сумму X ^ 1 + X ^ 2 + X ^ 3 + .

+ X ^ nX И вывести её на экран.

Python!

Цикл : for.

На этой странице находится вопрос Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.