Определи, что будет выведено в результате работы программы, если ввести число9696 :program prog ;var i, x, j : integer ;const arr : array [1?

Информатика | 5 - 9 классы

Определи, что будет выведено в результате работы программы, если ввести число

96

96 :

program prog ;

var i, x, j : integer ;

const arr : array [1.

10] of integer = (59, 32, 96, 84, 74, 69, 95, 18, 65, 96) ;

begin

j : = 0 ;

readln(x) ;

for i : = 1 to 10 do if arr[i] = x then j : = i ;

write(j) ;

end.

Запиши в поле ответа верное число.

Ответить на вопрос
Ответы (1)
Melkayaaaaaa 2 мар. 2024 г., 13:17:34

Ответ :

3

Объяснение :

i = 1 arr(1) = 96 F

i = 2 arr(2) = 96 F

i = 3   ; arr(3) = 96 T j = 3 печатать 3.

Dandyd 10 мар. 2024 г., 04:48:51 | студенческий

ДАЮ 30 БАЛЛОВ?

ДАЮ 30 БАЛЛОВ!

Выдает такую ошибку, что мне надо исправить я не понимаю Fatal : Syntax error, ")" expected but "identifier D" found Program P2 ;

var a, b : integer ; d, s, p : real ;

Begin

write('введите сторону прямоугольника a = ') ;

readln(a) ;

write('введите сторону прямоугольника b = ') ;

readln(b) ; d : = sqrt(sqr(a) + sqr(b)) ;

writeln('диагональ прямоугольника = 'd) ;

s : = a * b ;

writeln('площадь прямоугольника = 's) ;

p : = 2 * (a + b) ; writeln('периметр прямоугольника = 'p) ;

end.

SENSEY11111 23 янв. 2024 г., 18:37:43 | студенческий

Выдает такую ошибку , в чем проблема?

Выдает такую ошибку , в чем проблема?

Source.

Pas(13, 11) Fatal : Syntax error, ")" expected but "(" found

Program P1 ;

var a, b, c : integer ;

s, p : real ;

Begin

write('введите координату a = ') ; readln(a) ; write('введите координату b = ') ;

readln(b) ; write('введите координату c = ') ; readln(c) ; P : = (a + b + c) / 2 ;

writeln('периметр треугольника = ', P : 2 : 2) ;

s : = sqrt(p(p - a) * (p - b) * (p - c)) ; writeln('площадь треугольника = ', s : 2 : 2) ;

end.

Tolyamenseitov 3 янв. 2024 г., 10:12:21 | 10 - 11 классы

Перед вами фрагмент программы :a : = 2018 ;b : = a + 2 ;a : = b - a ;write(b, a) ;Какие числа будут выведены на экран?

Перед вами фрагмент программы :

a : = 2018 ;

b : = a + 2 ;

a : = b - a ;

write(b, a) ;

Какие числа будут выведены на экран?

В качестве ответ запишите числа, разделяя их одинарным пробелом, например, 1 2.

​.

EvdokiomovaUna 16 янв. 2024 г., 19:45:36 | 5 - 9 классы

Дана часть программы?

Дана часть программы.

Определите число, которое выведет программа на экран.

Urinkovanadezhd 26 янв. 2024 г., 13:56:32 | 1 - 4 классы

ПОМОГИТЕ ПОЖАЛУЙСТАЗаписать программу на языке Паскаль и определить, что будет выведено в результате работы программы?

ПОМОГИТЕ ПОЖАЛУЙСТА

Записать программу на языке Паскаль и определить, что будет выведено в результате работы программы.

От программы, записанной на алгоритмическом языке, перейти к записи программы на языке Паскаль.

Определить, что будет выведено в результате работы программы.

Алгоритмический язык :

алг

цел s, k

нач

s : = 0

k : = 0

нц пока k< ; 6

s : = s + 2

k : = k + 1

кц

вывод s

кон.

ДдддАааа 2 февр. 2024 г., 01:57:06 | студенческий

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры?

Написать программу, которая проверяет, делится ли на 3 число введенная с клавиатуры.

Если да то, выполните деление, если нет, то выведите на экран сообщение что нельзя поделит без остатка.

Помогите пж!

AnnCherevko2005 23 февр. 2024 г., 15:03:58 | 10 - 11 классы

Люди подскажите где ошибка, пожалуйста?

Люди подскажите где ошибка, пожалуйста.

Это Pascal

когда компилирую это и ввожу числа 10 и 5 ответ выходит 0.

0​

program h ;

var a : real ;

b : real ;

c : real ;

begin

a : = b + c ;

WriteLn('Введите числа, которые необходимо сложить : ') ;

readln(b) ;

readln(c) ;

Writeln('Ответ : ', a) ;

end.

Tinkakthiksak 30 янв. 2024 г., 15:04:55 | 5 - 9 классы

Дан фрагмент программы а : = 4 ; б : = а + 4 ; а : = б - а ; write(а, б)какие числа будут выведены на экран компьютера ?

Дан фрагмент программы а : = 4 ; б : = а + 4 ; а : = б - а ; write(а, б)

какие числа будут выведены на экран компьютера ?

Artem4eg2004 26 февр. 2024 г., 22:10:58 | 5 - 9 классы

Вычислите значение а и b на каждом шаге?

Вычислите значение а и b на каждом шаге.

Запишите ответ рядом с каждым

выражением.

Program qq ;

var a, b : integer ;

begin a : = 5 ; b : = a + 2 ; a : = (a + 2) * (b – 3) ; b : = a + 5 ; a : = a - b ; a : = a + 1 ; b : = (a + 6) * 7 ;

end.

Dkhaliov1 26 мар. 2024 г., 00:12:31 | студенческий

Переведите с Паскаля на c + + :var count, min, i : integer ;begin min : = 20000 ; count : = 0 ; for i : = 7525 to 13486 do begin if i mod 7 = 0 then if i mod 6 < ; > ; 0 then if i mod 9 < ; > ?

Переведите с Паскаля на c + + :

var count, min, i : integer ;

begin min : = 20000 ; count : = 0 ; for i : = 7525 to 13486 do begin if i mod 7 = 0 then if i mod 6 < ; > ; 0 then if i mod 9 < ; > ; 0 then if i mod 14 < ; > ; 0 then if i mod 21 < ; > ; 0 then begin count : = count + 1 ; if i < ; min then min : = i ; end ; end ; writeln(count, min) ;

end.

​.

На этой странице сайта вы найдете ответы на вопрос Определи, что будет выведено в результате работы программы, если ввести число9696 :program prog ;var i, x, j : integer ;const arr : array [1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.