1. Найти и вывести на экран все целые числа из промежутка от 1 до K, которые заканчиваются на цифру 32?

Информатика | 5 - 9 классы

1. Найти и вывести на экран все целые числа из промежутка от 1 до K, которые заканчиваются на цифру 3

2.

Найти сумму четных целых чисел на промежутке от 1 до K.

3. Вывести все натуральные трехзначные числа, в которых есть заданная цифра.

НА ПАСКАЛЕ, СРОЧНО.

Ответить на вопрос
Ответы (1)
Mesheryakovavika 23 нояб. 2023 г., 20:46:41

1)

Var K, I : Integer ;

Begin

ReadLn(K) ;

For I : = 1 to K do Begin   ; If (I - (I div 10) * 10) mod 10 = 3 then WriteLn(I) ;

End ;

End.

2)

Var K, I : Integer ;   ; O : Longint ;

Begin

ReadLn(K) ;

For I : = 1 to K do Begin   ; If I div 2 = I / 2 then   ; O : = O + I ;

End ;

WriteLn(O) ;

End.

3) Var A, I, O : Integer ;

Begin

ReadLn(A) ;

For I : = 100 to 999 do Begin   ; If I div 100 = A Then   ;   ; O : = O + 1 ;   ; if (I div 10) - (I div 100) = A then   ;   ; O : = O + 1 ;   ; If I - ((I div   ; 10) * 10) = A Then   ;   ; O : = O + 1 ;

End ;

WriteLn(O) ;

End.

Я такое уже отвечал.

Валерийкаст1 12 окт. 2023 г., 16:08:00 | 5 - 9 классы

Составить программу выводящую на экран все двузначные числа у которых вторая цифра нечетная?

Составить программу выводящую на экран все двузначные числа у которых вторая цифра нечетная.

Андрей1245 11 нояб. 2023 г., 03:56:49 | 5 - 9 классы

Помогите написать программу по информатике?

Помогите написать программу по информатике.

Напишите программу которая выдает произведения только четных целых чисел.

Swan426y 20 нояб. 2023 г., 17:05:40 | 10 - 11 классы

Напишите программу?

Напишите программу.

Дано натуральное число.

Найти сумму его цифр, кратных 7.

Ева461 25 нояб. 2023 г., 06:29:37 | 5 - 9 классы

Здравствуйте?

Здравствуйте!

Помогите пожалуйста решить 2 задачу с Паскалем.

(я просто вообще не шарю в этом, а писать всё равно нада хех)

Вопрос :

Напишите процедуру, в которой определяется сумма четных цифр числа N.

Процедуру включите в программу, в которой пользователь вводит N, запускается процедура и программа печатает ответ.

​.

Natash198405 7 дек. 2023 г., 06:04:05 | студенческий

ДАЮ ВСЕ БАЛЛЫ?

ДАЮ ВСЕ БАЛЛЫ!

Задача 3 : Соревнование делимости

Кате нравятся целые числа, которые делятся без остатка на число K, а Маше — целые числа, которые делятся без остатка на число M.

Сегодня подруги решили утроить соревнование и выяснить, чьи любимые числа лучше.

Для начала они выписали на лист бумаги все целые числа от A до B включительно.

Затем Катя посчитала, сколько чисел среди выписанных делятся на число K без остатка, а Маша посчитала, сколько чисел делятся на число M без остатка.

В соревновании победит та из них, чьих любимых чисел окажется больше.

Если же количества любимых чисел Кати и Маши совпадут, объявляется ничья.

Для того, чтобы определить победителя, девочки попросили вас вычислить разность количества любимых чисел Кати и Маши.

Входные данные

Программа получает на вход четыре целых положительных числа, записанных в отдельных строках : K, M, A и B.

Числа не превосходят 2×109.

Выходные данные

Программа должна вывести одно целое число — разность количества любимых чисел Кати и количества любимых чисел Маши.

Система оценивания

Решение, правильно работающее только для случаев, когда входные числа не превосходят 100, будет оцениваться в 60 баллов.

Diceklid 25 дек. 2023 г., 23:09:19 | студенческий

Phyton 3Вывести на экран все числа от 1 до числа, которое указал пользователь?

Phyton 3

Вывести на экран все числа от 1 до числа, которое указал пользователь.

Olyaavdeichik 26 дек. 2023 г., 22:41:19 | 10 - 11 классы

Составьте программу которая формирует массив из 16 случайных чисел промежутку - 10, 10 и вычислить сумму этих чисел?

Составьте программу которая формирует массив из 16 случайных чисел промежутку - 10, 10 и вычислить сумму этих чисел.

Kazimirov1964 12 окт. 2023 г., 03:09:49 | студенческий

СРОЧНО?

СРОЧНО!

ДАМ 100 БАЛЛОВ

Создайте любую переменную, в которую пользователь будет вводить свое имя.

Затем выведите с приветствием имя пользователя.

Пример : “Здравствуй, Боб!

2. Пользователь вводит любое число, если оно десятичное, то вывести : “Это число не целое”, а иначе “Число целое”.

Пример : 23.

5 или 54.

5 –> ; не целое число (используйте in)

3.

Создать 4 числовые переменные, где пользователь вводит значения.

Нужно вывести самое наименьшее число и наибольшее

4.

Создать одну переменную, пользователь вводит в нее значение и программа должна вывести :

1)Если число четное и больше 50 : “Категория А” 2)Если число четное и меньше 50 : ”Категория В” 3)Если число нечетное и больше 50 : “Категория C” 4)Если число нечетное и меньше 50 : “Категория D”

5.

Пользователь вводит 2 числа и 1 символ, к примеру + , то вывод должен быть суммой двух чисел (в общем пользователь может ввести 4 символа : + , - , / , * ).

Katyushaturlak 3 нояб. 2023 г., 15:54:49 | 5 - 9 классы

Массив из 8 целых чисел сформирован случайным образом на промежутке [ - 8, 8] выведите на экран элементы исходного массива, увеличив их на 10?

Массив из 8 целых чисел сформирован случайным образом на промежутке [ - 8, 8] выведите на экран элементы исходного массива, увеличив их на 10.

KIRILLGERLES 18 нояб. 2023 г., 12:30:58 | 5 - 9 классы

Написать программу : с клавиатуры вводятся два целых числа?

Написать программу : с клавиатуры вводятся два целых числа.

Вывести количество целых чисел находящихся между двумя введенными числами.

Сами числа не учитываются.

Пример работы программы : Введите два числа : 1 5 Ответ : 3 Или Введите два числа : 4 10 Ответ : 5 * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *.

Вы находитесь на странице вопроса 1. Найти и вывести на экран все целые числа из промежутка от 1 до K, которые заканчиваются на цифру 32? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.