PASCAL?

Информатика | студенческий

PASCAL.

Сколько раз в целом числе встречается самая маленькая цифра этого числа( решение через процедуру, надеюсь на вашу помощь!

).

Ответить на вопрос
Ответы (1)
Ника707 24 мар. 2022 г., 23:57:22

Pascal ABC.

Процедура.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

var N : longint ; min : longint ; count : byte ; tmp, z : longint ;

procedure MinAndCount(var a : longint) ;

begin

readln(N) ;

z : = N ;

count : = 0 ;

min : = 10 ;

while N0 do

begin if n mod 10 < min then min : = n mod 10 ; n : = n div 10 ;

end ;

tmp : = min ;

while z0 do

begin

if (z mod 10) = tmp then inc(count) ;

z : = z div 10 ;

end ;

writeln('Самая маленькая цифра = ', min, ' встречается = ', count, ' раз(а).

') ;

readln ;

end ;

begin write('Введите число : ') ; MinAndCount(N) ;

end.

Katiushaivanov 7 мар. 2022 г., 16:40:10 | студенческий

Написать на Pascal программу?

Написать на Pascal программу.

Определить , являеться ли число N четным двузначным числом.

Nastyas200396 18 янв. 2022 г., 03:13:50 | 10 - 11 классы

По шестнадцатеричной форме внутреннего представления целого числа в 2 - х байтовой ячейки восстановить само число?

По шестнадцатеричной форме внутреннего представления целого числа в 2 - х байтовой ячейки восстановить само число.

(F7CB).

Линка43 18 апр. 2022 г., 06:02:39 | 10 - 11 классы

Дано трехзначное число?

Дано трехзначное число.

Определить, является ли сумма его цифр кратна 3 и 5.

Написать программу на C + + и Pascal.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Капелькаяда1 18 апр. 2022 г., 04:02:49 | студенческий

Дано целое число K?

Дано целое число K.

Найти произведение цифр числа К.

Язык - С + + .

Нужен код внутри int main().

Panin1 12 февр. 2022 г., 09:03:01 | 10 - 11 классы

Написать программу в С + + Дано натуральное число?

Написать программу в С + + Дано натуральное число.

Определить, сколько раз в нём встречается максимальная цифра.

Ilia0451 29 апр. 2022 г., 01:18:29 | 5 - 9 классы

Определить симметричность введенного четырехзначного числа если да вывести 1 если нет любое число написать в pascal?

Определить симметричность введенного четырехзначного числа если да вывести 1 если нет любое число написать в pascal.

Musta03 27 янв. 2022 г., 01:56:51 | 5 - 9 классы

Найти разность между произведением и суммой цифр трехзначного числа?

Найти разность между произведением и суммой цифр трехзначного числа.

Pascal.

Vasinsasha92 23 мая 2022 г., 15:45:55 | 10 - 11 классы

35 балов?

35 балов!

Помогите пожалуйста с информатикой, решить задачи в бейсике.

1)дано целое число, определить оканчивается ли оно чётной цифрой.

2) проверить.

Принадлежит ли число , введённое с клавиатуры.

Интервалу ( - 5, 3).

3) дано двузначное число.

Определить является ли его сумма цифр двузначным числом.

4) дано двузначное число, определить больше ли числа А сумма его цифр.

5) дано двузначное число, определить кратна ли трём сумма его цифр.

6) дано двузначное число.

Определить кратна ли сумма его цифр числу А.

7)дано двузначное число.

Определить водит ли в него цифра 3.

8)дано двузначное число определить какая из его цифр больше : первая или вторая.

9)даны 4 вещественных числа.

Определить сколько из них отрицательных.

Kioli1234 29 мар. 2022 г., 16:38:44 | 5 - 9 классы

Сколько трехзначных числе можно записать с помощью цифр 0, 1, 2 и 3 при условии, что в записи числа не должны быть одинаковых цифр?

Сколько трехзначных числе можно записать с помощью цифр 0, 1, 2 и 3 при условии, что в записи числа не должны быть одинаковых цифр?

Выпишите все такие числа.

Если вам необходимо получить ответ на вопрос PASCAL?, относящийся к уровню подготовки учащихся студенческий, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.