Программа получает на вход количество чисел в последовательности, а затем сами числа?

Информатика | 5 - 9 классы

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Количество чисел не превышает 1000.

Введённые числа по модулью не превышают 30 000.

Программа должна вывести одно число : сумму чисел, кратных 7 и оканчивающихся на 4.

Ответить на вопрос
Ответы (1)
Fagejsi 11 апр. 2022 г., 15:33:49

/ / PascalABC.

NET

var s : integer ;

begin var n : = ReadlnInteger('Сколько будет чисел?

') ; writeln('Вводите числа') ; var a : = ReadArrInteger(n) ; for var i : = 0 to n - 1 do if (a[i] mod 10 = 4) and (a[i] mod 7 = 0) then s : = s + a[i] ; writeln('Сумма чисел равна ', s)

end.

ТетеринКирилл 13 янв. 2022 г., 07:39:59 | 5 - 9 классы

. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6?

. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 6.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность через repeat until.

Akaygorodtsev 28 янв. 2022 г., 13:28:17 | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел?

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

ЛанаЧ200312 8 февр. 2022 г., 01:42:52 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры

б) сумма квадратов чисел в диапазоне от 1 до n

в) количество натуральных чисел не превышающих 50 и кратных 3.

НеЕдинорог11 9 янв. 2022 г., 10:49:24 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3?

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 1000.

Введённые числа не превыша ют 30 000.

Программа должна вывести одно число — минимальное число, кратное 3.

Zhuzhkova89 1 мар. 2022 г., 02:13:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 1?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 1.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, оканчивающееся на 1.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число – максимальное число, оканчивающееся на 1.

Пример работы программы : Входные данные : 3 11 21 31 Выходные данные : 31.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Zaskalov 23 февр. 2022 г., 09:09:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа ролучает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число - сумму чисел, кратных 3.

Lerynya1 14 апр. 2022 г., 21:25:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи - вается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число : сумму всех чисел, кратных 3 и оканчивающихся на 8.

Пример работы программы : Входные данные Выходные данные 23 48 12 18 34 0 66.

Ksa84 3 янв. 2022 г., 21:12:08 | 5 - 9 классы

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0?

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).

2. Что будет на экране после выполнения программы

Var I, s, k : integer ;

Begin .

S : = 0 ;

for i : = 0 to 10 do

s : = s - i + 5 ; writeln(s) ;

End.

Даша2900 28 февр. 2022 г., 13:36:14 | 1 - 4 классы

9 класс ?

9 класс !

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму чётных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — при знак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

На этой странице находится вопрос Программа получает на вход количество чисел в последовательности, а затем сами числа?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.