Написать программу в паскаль ABC, генератор чисел от 0 до 1 с 16 знаками после запятой(пример 0?

Информатика | 10 - 11 классы

Написать программу в паскаль ABC, генератор чисел от 0 до 1 с 16 знаками после запятой(пример 0.

0000000000000002) и записать эти данные в файл txt по возрастанию.

Ответить на вопрос
Ответы (1)
Евелина 19 мая 2022 г., 03:35:31

Как то так, можно улучшить конечно, но числа генерируются в нужном интервале, если найду что получше, то перепешу

var

a : array[1.

1000] of real ;

i, x, j : integer ;

cur : real ;

l : text ;

label y ;

begin

assign(l, 'output.

Txt') ;

rewrite(l) ;

randomize ;

for i : = 1 to 999 do

begin

y :

cur : = 0.

96743612142 / ( random(24) + random(11) + random(7)) ;

x : = random(100) ;

if x > 20 then if cur < 0.

4 then cur : = cur * random(5) ;

if (cur = 0) or (cur > 1)then goto y ;

a[i] : = cur ;

end ;

for i : = 1 to 999 do for j : = 1 to 999 do if a[j] > a[i] then swap(a[j], a[i]) ;

for i : = 1 to 999 do writeln(l, a[i] : 0 : 16) ;

close(l) ;

end.

= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =

Улучшенная версия

var a : array[1.

1000] of real ; i, x, j : integer ; cur, tmp : real ; l : text ;

label y, z ;

begin assign(l, 'output.

Txt') ; rewrite(l) ; randomize ; for i : = 1 to 999 do begin y : tmp : = 1 - 1 / (random(33) + random(11) + random(7)) ; if tmp < 0.

4 then goto y ; cur : = tmp / abs(random(24) + random(11) - random(7)) ; if cur > 0.

8 then begin x : = random(10000) ; if x < random(10000) then begin cur : = cur / (1 - 1 / (random(10) + random(11) + random(7))) ; end ; end ; x : = random(100) ; if x > 50 then if cur < 0.

5 then cur : = cur * random(5) ; if cur < 0.

1 then begin x : = random(10000) ; if x < 7000 then cur : = cur * random(8) ; end ; if cur > 0.

8 then cur : = cur - 1 / (random(10) + random(11) + random(7)) - 1 / (random(10) + random(11) + random(7)) + 1 / (random(10) + random(11) + random(7)) + 1 / (random(10) + random(11) + random(7)) ; if (cur = 0) or (cur > 1) then goto y ; a[i] : = cur ; end ; for i : = 1 to 999 do for j : = 1 to 999 do if a[j] > a[i] then swap(a[j], a[i]) ; for i : = 1 to 999 do writeln(l, a[i] : 0 : 16) ; close(l) ;

end.

Alfiya1972 2 февр. 2022 г., 07:13:16 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТАНапишите программу которая считает из файла input?

ПОМОГИТЕ ПОЖАЛУЙСТА

Напишите программу которая считает из файла input.

Txt целое число, определяет является ли оно простым и записать результат в файл output.

Txt.

Katenok228 26 янв. 2022 г., 21:24:36 | студенческий

Графика паскаль написать программу?

Графика паскаль написать программу.

Katyushkapugin 16 февр. 2022 г., 21:47:00 | 5 - 9 классы

Составить программу, в которой осуществляется ввод строки информации с клавиатуры и сохранение ее в текстовый файл с расширением ?

Составить программу, в которой осуществляется ввод строки информации с клавиатуры и сохранение ее в текстовый файл с расширением .

Txt

Pascal ABC.

Lexan4223 11 янв. 2022 г., 16:35:36 | 1 - 4 классы

Нужно написать программу для ПАСКАЛЬ АВС, (тема : Циклы с пред - пост - условием)что бы программа выводила на экран знак « * » до тех пор, пока не будет введен с клавиатуры знак «0»?

Нужно написать программу для ПАСКАЛЬ АВС, (тема : Циклы с пред - пост - условием)что бы программа выводила на экран знак « * » до тех пор, пока не будет введен с клавиатуры знак «0».

Poromon 28 мая 2022 г., 22:35:58 | 10 - 11 классы

Как записать данное выражение в программе С + + ?

Как записать данное выражение в программе С + + ?

Clientmobi0001 29 апр. 2022 г., 05:05:32 | студенческий

Не получается написать программу в Паскале?

Не получается написать программу в Паскале.

Помогитеее.

Kristinakristi35 21 янв. 2022 г., 04:41:20 | 10 - 11 классы

Написать программу на паскале ?

Написать программу на паскале ?

Ockurovamarina 21 мая 2022 г., 13:29:04 | 5 - 9 классы

Составить алгоритм сложения двух целых чисел C и Q, вводимых с клавиатуры?

Составить алгоритм сложения двух целых чисел C и Q, вводимых с клавиатуры.

Результат сложения записать в виде переменной Z.

По данному алгоритму написать программу в Паскале.

Mr853 16 февр. 2022 г., 20:54:42 | 5 - 9 классы

Составить алгоритм сложения двух целых чисел B и Q, вводимых с клавиатуры?

Составить алгоритм сложения двух целых чисел B и Q, вводимых с клавиатуры.

Результат сложения записать в виде переменной Z.

По данному алгоритму написать программу в Паскале.

Хорошо55 26 мар. 2022 г., 10:17:31 | 5 - 9 классы

Будьте добры, помогите с задачей в Паскале?

Будьте добры, помогите с задачей в Паскале!

Желательно с объяснением)

Пользователь водит 5 чисел.

Записать их в порядке возрастания в одну строку через запятую.

Вы зашли на страницу вопроса Написать программу в паскаль ABC, генератор чисел от 0 до 1 с 16 знаками после запятой(пример 0?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.