Pascal?

Информатика | 10 - 11 классы

Pascal.

Найти и напечатать индекс наименьшего элемента одномерного массива P размерности 5 элементов.

Из равных наименьших элементов выбрать элемент с большим индексом.

Что не так с кодом?

Ответить на вопрос
Ответы (1)
Valya31254 2 февр. 2022 г., 20:00:51

Type

vect = array[1.

5]of integer ;

var

p : vect ; i, min, imin : integer ;

begin

writeln('Введите массив : ') ;

for i : = 1 to 5 do read(p[i]) ;

readln ;

min : = p[i] ; imin : = 1 ;

for i : = 2 to 5 do

if p[i].

0809annie 28 янв. 2022 г., 04:01:38 | 5 - 9 классы

Помогите изменить массив :Дан одномерный целочисленный массив mas?

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Макс12908478985 26 янв. 2022 г., 16:34:04 | 10 - 11 классы

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива?

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива.

Начертить алгоритм и написать программу.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

Bal1 2 мар. 2022 г., 03:03:21 | 5 - 9 классы

СРОЧНОО 1?

СРОЧНОО 1.

НАйти произведение элементов с нечетными номерами(паскаль, массивы)

2.

Найти сумму четных элементов массива(паскаль, массивы).

Котик1236 28 февр. 2022 г., 07:34:55 | студенческий

Какие параметры элементов ЭВМ влияют на индекс производительности?

Какие параметры элементов ЭВМ влияют на индекс производительности?

SevenNationArmy 1 мар. 2022 г., 01:31:07 | 5 - 9 классы

Составьте программу ввода с клавиатуртуры элементов массива a [1?

Составьте программу ввода с клавиатуртуры элементов массива a [1.

10] и вывода на экран элементов с четными индексами.

Katykolomeiceva 1 апр. 2022 г., 03:07:07 | 5 - 9 классы

Массив - 10 элементов?

Массив - 10 элементов.

Задача :

Удвоить все четные элементы массива.

Все элементы с нечетным номером разделить на первый

элемент массива.

Срочно!

Завтра сдавать Дз.

Кнопа20010502 19 апр. 2022 г., 09:46:31 | 10 - 11 классы

Массив состоит из 40 элементов?

Массив состоит из 40 элементов.

Значение от 1 до 10000.

Найти и вывести наименьший элемент массива, восьмеричная запись которого заканчивается 7.

Если такого элемента нет, вывести 0.

Dan34111 7 янв. 2022 г., 10:14:06 | студенческий

Помогите пожалуйста задание, надо код для паскали?

Помогите пожалуйста задание, надо код для паскали.

Дан одномерный массив, найти сумму всех четных элемент массива, кратных заданному числу.

Sonic1231 5 февр. 2022 г., 04:26:57 | 5 - 9 классы

Ответьте на вопросы?

Ответьте на вопросы.

1. Как в программе обратиться к конкретному элементу массива?

2. Как называется номер элемента массива?

3. Какие способы заполнения одномерного массива вы знаете?

Вы перешли к вопросу Pascal?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.