Написать функцию, которая возвращает сумму первой и последней цифр входящих в запись числа типа Longint ?

Информатика | 10 - 11 классы

Написать функцию, которая возвращает сумму первой и последней цифр входящих в запись числа типа Longint .

Ответить на вопрос
Ответы (2)
Ксюхабро 11 янв. 2022 г., 02:19:01

Function f(x : longint) : integer ;

var s : integer ;

begin

s : = x mod 10 ;

while x>9 do x : = x div 10 ;

f : = s + x ;

end ;

begin

writeln(f(6120879)) ;

end.

Результат :

15.

Alexh547 11 янв. 2022 г., 02:19:05

Var x : longint ; k, s : integer ;

begin

readln(x) ;

s : = x mod 10 ;

while x>0 do begin

k : = x mod 10 ;

x : = x div 10 ;

end ;

s : = s + k ;

writeln(s) ;

end.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Bunaeva2016 5 янв. 2022 г., 18:48:08 | 5 - 9 классы

Надо решить то что на фото и то что я сейчас напишу в скобках , и это всё надо написать в языке паскаль " сумма цифр четырёхзначного числа "?

Надо решить то что на фото и то что я сейчас напишу в скобках , и это всё надо написать в языке паскаль " сумма цифр четырёхзначного числа ".

Maxkorzhnev 7 янв. 2022 г., 06:32:51 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО1) с клавиатуры вводятся два целых числа А и В?

ПОМОГИТЕ СРОЧНО

1) с клавиатуры вводятся два целых числа А и В.

Написать программу, которая выводит число 1, если числа равны, и число 0 в противно случае.

2) написать программу, в которой подсчитывается сумма только положительных чисел из трёх данных.

3) определить принадлежит ли точка с координатами (x, y) первой четверти.

Всё надо в паскале написать.

ЛанаЧ200312 8 февр. 2022 г., 01:42:52 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры

б) сумма квадратов чисел в диапазоне от 1 до n

в) количество натуральных чисел не превышающих 50 и кратных 3.

Mishan9lm 9 мар. 2022 г., 01:54:43 | студенческий

Поменять местами первую и последнюю цифру числа n?

Поменять местами первую и последнюю цифру числа n.

Gnomik1231 8 мар. 2022 г., 13:09:47 | 10 - 11 классы

Ввести шестизначное число с клавиатуры?

Ввести шестизначное число с клавиатуры.

Проверить, является ли оно счастливым (суммы первых трех цифр равна сумме последних трех).

Линка43 18 апр. 2022 г., 06:02:39 | 10 - 11 классы

Дано трехзначное число?

Дано трехзначное число.

Определить, является ли сумма его цифр кратна 3 и 5.

Написать программу на C + + и Pascal.

Гая234 24 февр. 2022 г., 16:41:11 | 5 - 9 классы

Не(первое число четное)и(последняя цифра не четная)1)12342)68433)35614)4562?

Не(первое число четное)и(последняя цифра не четная)

1)1234

2)6843

3)3561

4)4562.

KasenkovaSasha 30 янв. 2022 г., 16:19:22 | 5 - 9 классы

Составьте программу, печатающую значение TRUE, если указанное высказывание является истинным, и FALSE в противном случае : сумма двух первых цифр заданного четырехзначного числа равна сумме двух его п?

Составьте программу, печатающую значение TRUE, если указанное высказывание является истинным, и FALSE в противном случае : сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр

В паскале.

Dianamitul 15 янв. 2022 г., 01:37:01 | 5 - 9 классы

Написать программу о нахождении двухзначного числа А?

Написать программу о нахождении двухзначного числа А.

Найти сумму и произведение цифр данного числа, а также вывести новое число, в котором цифры числа А поменялись местами.

На этой странице сайта размещен вопрос Написать функцию, которая возвращает сумму первой и последней цифр входящих в запись числа типа Longint ? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.