Спектакль начинается в а часов b минут и заканчивается в c часов d минут (в те же сутки)?

Информатика | 5 - 9 классы

Спектакль начинается в а часов b минут и заканчивается в c часов d минут (в те же сутки).

Определите продолжительность спектакля.

Входные данные

Вводятся четыре целых не отрицательных числа a , b , c , d , разделенные пробелом.

A и c не превосходят 23, b и d не превосходят 59.

Гарантируется, что либо a < c , либо ( a = c и b < d ).

Выходные данные

Выведите через пробел два числа — часы и минуты.

Второе число не должно превосходить 59.

СДЕЛДАТЬ НА PASCAL ABC.

Ответить на вопрос
Ответы (1)
Абсдв 18 мая 2022 г., 20:44:25

Var a, b, c, d, h, m : integer ;

begin

readln(a, b, c, d) ;

h : = (c * 60 + d - a * 60 - b) div 60 ;

m : = (c * 60 + d - a * 60 - b) mod 60 ;

writeln(h, ' ', m) ;

end.

Пример :

18 30 21 15

2 45.

Yolchuevanar 7 янв. 2022 г., 15:24:04 | 5 - 9 классы

Дано четыре целых числа?

Дано четыре целых числа.

Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные

Входные данные : с клвиатуры вводится 4 целых числа

Выходные данные : необходимо вывести на экран преобразованные числа в той же последовательности

Пример входных и выходных данных

Входные данные

3 5 - 2 - 4

Выходные данные

9 25 16 256

C + +.

Stroyka8585 16 мар. 2022 г., 14:44:03 | 5 - 9 классы

Даны n целых чисел?

Даны n целых чисел.

Ваша программа должна найти их сумму , В первой строке записано натуральное число n, n≤1000.

Во второй строке через пробел записаны n целых чисел.

Числа по абсолютному значению не превосходят 1000.

Аня2002Петрова 4 мар. 2022 г., 02:14:39 | 1 - 4 классы

ДЛЯ ПИТОНАДано натуральное число N?

ДЛЯ ПИТОНА

Дано натуральное число N.

Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае.

Операцией возведения в степень пользоваться нельзя!

Входные данные

Вводится натуральное число.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

3

выходные данные

NO

входные данные

8

выходные данные

YES.

Тёма210 14 февр. 2022 г., 03:09:53 | 5 - 9 классы

ДЛЯ ПИТОНАНапишите функцию min4(a, b, c, d), вычисляющую минимум четырех чисел, которая не содержит инструкции if, а использует стандартную функцию min?

ДЛЯ ПИТОНА

Напишите функцию min4(a, b, c, d), вычисляющую минимум четырех чисел, которая не содержит инструкции if, а использует стандартную функцию min.

Считайте четыре целых числа и выведите их минимум.

Входные данные

Вводятся четыре целых числа.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

4

5

6

7

выходные данные

4.

Ka2017 18 янв. 2022 г., 16:31:00 | 5 - 9 классы

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHONНа сковородку одновременно можно положить k котлет?

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHON

На сковородку одновременно можно положить k котлет.

Каждую котлету нужно с каждой стороны обжаривать m минут непрерывно.

За какое наименьшее время удастся поджарить с обеих сторон n котлет?

Входные данные

Вводятся 3 числа : k, m и n.

Все числа не превосходят 32000.

Выходные данные

Вывести время, за которое все котлеты будут обжарены.

Примеры

Входные данные

1

5

1

Выходные данные

10.

GooDStaf 10 мар. 2022 г., 07:14:29 | 5 - 9 классы

Дано целое число n?

Дано целое число n.

Выведите следующее за ним четное число.

Входные данные

Вводится целое положительное число, не превышающее 1000.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

7

выходные данные

8

входные данные

8

выходные данные

10.

Margo196 15 февр. 2022 г., 10:52:22 | 5 - 9 классы

Программа на C + +Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Программа на C + +

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Входные данные

Входная строка содержит два целых числа.

Выходные данные

Программа должна вывести произведение введённых чисел.

Примеры

входные данные

6 12

выходные данные

72

входные данные - 7 15

выходные данные - 105.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

На странице вопроса Спектакль начинается в а часов b минут и заканчивается в c часов d минут (в те же сутки)? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.