Пират положил в сундук некоторое количество золотых монет?

Информатика | 10 - 11 классы

Пират положил в сундук некоторое количество золотых монет.

На второй год он вынул из сундука сколько - то монет.

Начиная с третьего года, он добавлял столько монет , сколько было в сундуке два года назад.

Требуется написать программу, которая определит, сколько монет было в сундуке в первый и во второй год , в сундуке будет 5, 2, 7, 9, , 16, 25 .

Монет.

Формат входного файла :

Входной файл INPUT.

TXT содержит числа Х (3.

Ответить на вопрос
Ответы (1)
Vika5555555555 31 мар. 2022 г., 08:26:54

1. Вопрос задан коряво.

Задача эта называется сундук Билли Бонса, ряд

5, 2, 7, 9, 16, 25 - это пример последовательности числа монет в сундуке, если в первый год монет пять, во второй - две.

2. Вот программка на АБС - Паскале, не оптимальная по ряду моментов, но рабочая.

Из особенностей - выводит решения только если если во второй год монет становится меньше, чем в первый.

Существуют решения при нулевом количестве взятых во второй год монет и при отрицательном.

Если такие решения нужны - то условие в "if (j div n) < i then" надо изменить

Программка неэффективна, вместо решения диофантова уравнения по Евклиду используется тупой перебор, но по условиям он ограничен, и его можно себе позволить.

Выводятся также все решения, если нужно одно - прерывайте цикл по нахождению первого.

- - - - - - - - - - - - - - - - - - - - -

program БиллиБонс ; / /

const maxYear = 20 ; maxMoney = 32767 ;

var a, b : array [1.

MaxYear] of integer ; m, n, x, y : integer ; f1, f2 : text ; s : string ;

begin assign(f1, 'input.

Txt') ; / / устанавливаем связь между файловой переменной и путем к файлу reset(f1) ; / / открытие на чтение файла read(f1, x) ; read(f1, y) ; close(f1) ; / / закрываем файл / / Заполняем массив коэффициентов a[1] : = 1 ; b[1] : = 0 ; a[2] : = 0 ; b[2] : = 1 ; for var i : = 3 to maxYear do begin a[i] : = a[i - 1] + a[i - 2] ; b[i] : = b[i - 1] + b[i - 2] ; end ; m : = a[x] ; n : = b[x] ; / / решаем уравнение m * s1 + n * s2 = y / / m, n - коэффициенты, зависящие от номера года / / s1, s2 - монет в первый и второй годы assign(f2, 'output.

Txt') ; / / устанавливаем связь между файловой переменной и путем к файлу rewrite(f2) ; / / создание (перезапись) файла for var i : = 1 to y div m do / / цикл по s1 begin var j : = y - m * i ; if j mod n = 0 then if (j div n) < i then begin writeln('s1 = ', i, ' s2 = ', j div n) ; writeln(f2, i, ' ', j div n) ; / / вывод данных в файл end ; end ; close(f2) ; / / закрываем файл

end.

Alfiya1972 2 февр. 2022 г., 07:13:16 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТАНапишите программу которая считает из файла input?

ПОМОГИТЕ ПОЖАЛУЙСТА

Напишите программу которая считает из файла input.

Txt целое число, определяет является ли оно простым и записать результат в файл output.

Txt.

Djalilchik 3 янв. 2022 г., 09:42:27 | 5 - 9 классы

ИВТ 99 БАЛЛОВ?

ИВТ 99 БАЛЛОВ!

Напишите программу в паскале

Даны два БоЛьШуЩиХ ЧиСЛа.

Проверьте, делится ли их произведение на девять.

Формат файла входных данных :

В двух строках входного файла даны два целых неотрицательных числа, по одному в строке.

Запись каждого из них состоит из не более чем 106 цифр.

Формат файла выходных данных :

В единственной строке выходного файла выведите "YES", если произведение данных чисел делится на девять, и "NO" в противном случае (без кавычек).

Пример :

72

840

YES

3

5

NO

Ограничение по времени : 3 сек

Ограничение по памяти : 256 Мб

Обычная программа по типу перемножить числа и проверить, кратно ли произведение 9 НЕ ПОДХОДИТ

Пожалуйста, учитывайте ограничения по времени и памяти.

11122002 13 февр. 2022 г., 23:10:42 | студенческий

Какое количество информации получает человек , когда монета , им подкинутая падает орлом вверх?

Какое количество информации получает человек , когда монета , им подкинутая падает орлом вверх?

Помогитеееее.

Мроисодма 8 янв. 2022 г., 07:46:43 | студенческий

Какое количество информации содержит сообщение об исходе опыта бросания двух монет?

Какое количество информации содержит сообщение об исходе опыта бросания двух монет.

Срочно!

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Milavaneeva72 8 апр. 2022 г., 09:14:09 | 5 - 9 классы

Пожалуйста помогите до завтра ?

Пожалуйста помогите до завтра !

Добрыня Никитич и Алёша Попович нашли клад который состоял из 5 одинаковых монет.

Сундуки в котором лежали монеты богатырей обнаружили записку при помощи чашечных весов без гирь Найдите среди этих монет одну золотую за наименьшее число взвешиваний e - золотая монета более тяжелое Илья Муромец помог им справиться с этим заданием как действовали Богатыри Составьте план действий или блок схему Определите наименьшее число взвешиваний.

Катя45879 4 янв. 2022 г., 23:19:11 | 5 - 9 классы

Задача 9Дано натуральное четырехзначное число?

Задача 9

Дано натуральное четырехзначное число.

Найти наименьшую нечетную цифру в числовой записи данного числа.

Формат входных данных :

Входной файл содержит натуральное четырехзначное число.

Формат выходных данных :

Выведите наименьшую нечетную цифру в числовой записи данного числа.

Если нечетных цифр в числе нет, выведите в выходной файл - 1.

Примеры :

Вход

1234

Выход

1.

Ivanmy2013 17 апр. 2022 г., 04:24:21 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

ДАЮ 30 БАЛЛОВ!

С + +

Из файла «in.

Txt» вводятся отдельные символы.

Признак конца ввода —из файла последовательно считаны символы «e», «n»и «d».

Записать в файл «out.

Txt» :

общее количество считанных символов (целое число) ;

все считанные символы через пробел.

Примеры

входные данные

asdfendqwerty

выходные данные

7

a s d f e n d

входные данные

end?

Выходные данные

3

e n d

входные данные

what about end spaces?

Выходные данные

14

w h a t a b o u t e n d.

Абдул14 15 февр. 2022 г., 04:09:54 | 10 - 11 классы

Дима решил посчитать, сколько у него наград за N лет?

Дима решил посчитать, сколько у него наград за N лет.

У него награды разложены по годам и известно их количество.

Формат ввода :

N – количество лет (N.

Adyalera 17 февр. 2022 г., 04:44:26 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Найдите количество различных чисел.

Формат входных данных

Первая строка входного файла содержит целое число N (1.

На этой странице находится вопрос Пират положил в сундук некоторое количество золотых монет?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.