Дано натуральное число n?

Информатика | 5 - 9 классы

Дано натуральное число n.

Напишите программу ддя вычесленния суммы 1 / 1 + 1 / 2 + 1 / 3 + .

+ 1 / n.

Ответить на вопрос
Ответы (1)
Melena2001m 17 мар. 2022 г., 22:35:46

Program n1 ;

var n, i : integer ;

sum : real ;

begin

sum : = 0 ;

readln(n) ;

for i : = 1 to n do sum : = sum + 1 / i ;

write(sum) ;

end.

Akaygorodtsev 28 янв. 2022 г., 13:28:17 | 10 - 11 классы

На вход программы поступает последовательность из N натуральных чисел?

На вход программы поступает последовательность из N натуральных чисел.

Нужно выбрать из них произвольное количество чисел так, чтобы их сумма была максимальной и не делилась на 4.

В результате программа должна вывести количество выбранных чисел и их сумму.

Если получить требуемую сумму невозможно, в качестве ответа нужно выдать 0.

Входные данные :

На вход программе подаётся натуральное число N (N  1000), а затем N натуральных чисел, каждое из которых не превышает 10000.

Пример входных данных :

3

1

2

1

Выходные данные :

Программа должна вывести два числа : сначала количество выбранных чисел, а затем их сумму.

Пример выходных данных для приведённого примера входных данных :

2 3

паскаль.

Dima20066 1 февр. 2022 г., 19:46:33 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность.

Программа должна вывести одно число : сумму всех двузначных чисел, кратных 8.

Yanastolnikowa 18 янв. 2022 г., 13:43:22 | 5 - 9 классы

Напишите программу?

Напишите программу!

Является ли сумма трех чисел четным числом?

Lerynya1 14 апр. 2022 г., 21:25:11 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи - вается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число : сумму всех чисел, кратных 3 и оканчивающихся на 8.

Пример работы программы : Входные данные Выходные данные 23 48 12 18 34 0 66.

Tem04ka 12 апр. 2022 г., 15:21:31 | 5 - 9 классы

Задание решать на PYTHONВычислите сумму данных 100 натуральных чисел?

Задание решать на PYTHON

Вычислите сумму данных 100 натуральных чисел.

Входные данные

Вводятся 100 чисел, сумму которых необходимо посчитать.

Выходные данные

Программа должна вывести единственное число - полученную сумму.

Aleksandralogi 9 февр. 2022 г., 23:11:01 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Написать программу для вычисления суммы 1 / 1 + 1 / 2 + 1 / 3 + .

+ 1 / n.

Аьчндhfgkg 19 февр. 2022 г., 02:43:38 | 5 - 9 классы

Программа в C + +Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

Программа в C + +

Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

Входные данные

Входная строка содержит единственное число – требуемое количество чисел N .

Выходные данные

Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами.

Примеры

входные данные

5

выходные данные

2 4 6 8 10.

Рофаелка 2 янв. 2022 г., 10:18:55 | 10 - 11 классы

Программа на с + +Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр?

Программа на с + +

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.

Числа разделяются пробелами.

Animatrinikc 2 февр. 2022 г., 22:15:52 | 5 - 9 классы

Срочно 50 баллов напишите программу которая подсчитает сумму натуральных чисел от 1 до n?

Срочно 50 баллов напишите программу которая подсчитает сумму натуральных чисел от 1 до n.

Vtyvtyvtyb 27 февр. 2022 г., 16:46:29 | 10 - 11 классы

Составить алгоритм для вычесления суммы с заданным числом N численного ряда (цикл LOOP) и выполнить проверку данного алгоритма?

Составить алгоритм для вычесления суммы с заданным числом N численного ряда (цикл LOOP) и выполнить проверку данного алгоритма.

Писать программу для вычесления суммы НЕ НУЖНО!

Просто составить алгоритм и выполнить проверку.

Перед вами страница с вопросом Дано натуральное число n?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.