Задается положительное целое число N?

Информатика | 10 - 11 классы

Задается положительное целое число N.

Нужно вывести сумму его цифр.

Ответить на вопрос
Ответы (1)
Nataliaa241180 31 окт. 2020 г., 02:13:03

Program asd ;

vari, n : integer ;

begin

read(n) ;

while n> ; 0 do begin

i : = i + n mod 10 ;

n : = n div 10 ;

end ;

write(i) ;

end.

Rleisan 26 июн. 2020 г., 03:47:58 | 10 - 11 классы

Pascal?

Pascal.

Тема : Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа.

2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа.

Milana4569 25 авг. 2020 г., 21:39:45 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Но нужно сделать программу так чтобы она работала с любым числом.

Podgornyyn 25 нояб. 2020 г., 03:16:45 | 10 - 11 классы

Вводится целое положительное число?

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Yanovskyshura 23 нояб. 2020 г., 23:24:06 | 5 - 9 классы

Паскаль, цикл с предусловием while?

Паскаль, цикл с предусловием while.

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Эдвардик 3 авг. 2020 г., 13:26:54 | 5 - 9 классы

Дано целое положительное четырехзначное число?

Дано целое положительное четырехзначное число.

Напишите программу, позволяющую определить сумму двух первых цифр и разность двух последних цифр.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

SofArkadiu 12 нояб. 2020 г., 19:12:02 | 5 - 9 классы

PASCAL ABC, программа?

PASCAL ABC, программа!

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Ntoniy10 30 мар. 2020 г., 04:29:04 | 10 - 11 классы

Дан массив целых чисел, состоящий из 10 элементов?

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Вывести значения тех элементов, которые меньше заданного числа А кратны 3.

050778 7 апр. 2020 г., 07:08:51 | 5 - 9 классы

Помогите решить задачи в Паскале, пожалуйста) 1?

Помогите решить задачи в Паскале, пожалуйста) 1.

Найти и вывести на экран все целые числа из промежутка от 1 до K, которые заканчиваются на цифру 3.

K вводится с клавиатуры.

2. Вычислить сумму чётных и сумму нечётных целых чисел от 1 до 100 3.

С клавиатуры вводится целое положительное число.

Определить, сколько раз в этом числе встретилась цифра 5.

4. С клавиатуры вводится целое положительное число.

Определить, сколько в этом числе чётных цифр Заранее спасибо).

Любимаямоя 10 февр. 2020 г., 09:47:00 | 10 - 11 классы

Составить программу на Паскале?

Составить программу на Паскале.

Дано двухзначное число N.

Проверить, меньше ли сумма цифр числа N заданного числа К.

Вывести об этом сообщение и значения числа N и К.

На этой странице сайта вы найдете ответы на вопрос Задается положительное целое число N?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.