Если число заканчивается на 2 или 3, то исходное число умножить на число десятков в нем, если число единиц от 7 до 9, то из числа вычесть сумму цифр числа, в противном случае отбросить последнюю цифру?

Информатика | 1 - 4 классы

Если число заканчивается на 2 или 3, то исходное число умножить на число десятков в нем, если число единиц от 7 до 9, то из числа вычесть сумму цифр числа, в противном случае отбросить последнюю цифру.

Pascal.

Ответить на вопрос
Ответы (1)
Sammistayfly 25 июл. 2020 г., 23:10:45

Function summ(a : integer) : integer ;

begin

while(a< ; > ; 0) do begin summ + = a mod 10 ; a : = a div 10 ; end ;

end ;

var a : integer ;

begin

read(a) ;

if(a mod 10 = 2) or (a mod 10 = 3) then a * = (a div 10) mod 10

else if(a mod 10 > ; = 7) and (a mod 10 < ; = 9) then a - = summ(a)

else a : = a div 10 ;

writeln(a) ;

end.

Simma 23 янв. 2020 г., 23:27:23 | 10 - 11 классы

Написать программу, объясните?

Написать программу, объясните.

Ввести двухзначное число.

Если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2.

Ismagulovazama 20 сент. 2020 г., 18:27:59 | 5 - 9 классы

Трехзначное десятичное число заканчивается цифрой 3 ?

Трехзначное десятичное число заканчивается цифрой 3 .

Если эту цифру переместить на первое место слева в числе, то есть с неё будет начинаться запись нового числа то новое число будет на единицу больше утроенного исходного числа.

Найдите это число.

Nshaposhnik 29 мар. 2020 г., 18:01:36 | 5 - 9 классы

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой?

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой.

Danhek32 14 сент. 2020 г., 13:24:15 | 10 - 11 классы

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal)?

Водится 2 числа, вывести сумму цифр первого, если оно больше второго и произведение четных цифр второго числа в противном случае(pascal).

Ksenia1010 29 мая 2020 г., 16:30:59 | 5 - 9 классы

Шестнадцатеричное четырехзначное число начинается цифрой 9?

Шестнадцатеричное четырехзначное число начинается цифрой 9.

Последнюю цифру переставили в начало числа.

Полученное число оказалось на 677A ^ 16 меньше исходного.

Найти исходное число.

Ilyuxa34kalach 7 мар. 2020 г., 16:54:26 | 5 - 9 классы

Если цифра сотен равна 8 или 9, то число домножить на количество десятков, если число сотен от 3 до 5, то у числа оставить цифры сотен и десятков, в противном случае из исходного числа вычесть число с?

Если цифра сотен равна 8 или 9, то число домножить на количество десятков, если число сотен от 3 до 5, то у числа оставить цифры сотен и десятков, в противном случае из исходного числа вычесть число сотен?

Составьте пожалуйста программу?

))).

Dbrecm 29 сент. 2020 г., 00:41:45 | 5 - 9 классы

Трехзначное десятичное число оканчивается цифрой 3?

Трехзначное десятичное число оканчивается цифрой 3.

Если эту цифру переместить на первое слева место в числе, то есть с нее будет начинаться запись нового числа , то это новое число будет на единицу больше утроенного исходного числа .

Найдите исходное число.

Marinakhoroshi 26 февр. 2020 г., 03:52:15 | 10 - 11 классы

Задача в С + + ?

Задача в С + + .

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы цифре сотен числа а, увеличенной на цифру единиц числа а, число десятков в b обнулить, а вместо единиц поставить число десятков от числа а.

Alinplwww16 16 сент. 2020 г., 17:12:24 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти число, полученное при перестановке первой и последней

цифр заданного числа.

Pascal.

Полюсечка1 20 дек. 2020 г., 20:28:11 | 5 - 9 классы

Дано натуральное трехзначное число a?

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы сумме цифр числа единиц и десятков числа а, десятков в b равно увеличенному на 2 числу десятков в числе а, а вместо единиц поставить цифру 0.

C + +.

На этой странице находится вопрос Если число заканчивается на 2 или 3, то исходное число умножить на число десятков в нем, если число единиц от 7 до 9, то из числа вычесть сумму цифр числа, в противном случае отбросить последнюю цифру?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 1 - 4 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.