16. Составьте программу для вычисления числа n : n = 1∙2∙3∙…∙х?

Информатика | 5 - 9 классы

16. Составьте программу для вычисления числа n : n = 1∙2∙3∙…∙х.

Число Х вводится с клавиатуры.

Ответить на вопрос
Ответы (1)
Vipomeman13 26 февр. 2022 г., 04:42:15

Function factorial(n : integer) : BigInteger ;

var

i : integer ;

f : BigInteger ;

begin

f : = 1 ;

for i : = 2 to n do

f : = f * i ;

factorial : = f

end ;

var

x : integer ;

begin

write('X : ') ;

readln(x) ;

writeln(factorial(x)) ;

end.

Bablosikkkk 25 февр. 2022 г., 21:25:40 | 10 - 11 классы

11. Составить программу, осуществляющую ввод числовых переменных?

11. Составить программу, осуществляющую ввод числовых переменных.

Если число положительное, то вывести соответствующую информацию и выйти из программы.

Если число отрицательное, то вывести соответствующую информацию и вернуться на ввод.

Рейзудинфаталиев 13 апр. 2022 г., 05:06:49 | 10 - 11 классы

Напишите программу, которая вводит с клавиатуры два целых числа - длины сторон прямоугольника?

Напишите программу, которая вводит с клавиатуры два целых числа - длины сторон прямоугольника.

Затем программа должна вывести на экран друг перед другом : периметр прямоугольника, площадь прямоугольника.

TeriLis 13 апр. 2022 г., 04:02:47 | 5 - 9 классы

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран?

Составьте программу, которая сравнивает два целых числа введенных с клавиатуры - положительное и отрицательное и выводит положительное число на экран.

Солюся 6 февр. 2022 г., 22:00:18 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Составьте программу, которая позволяет определить код введенного с клавиатуры символа.

Пример ввода :

А (символ)

Пример ввода :

65 (код символа).

Saitovasaniatik 22 февр. 2022 г., 09:13:47 | 5 - 9 классы

Решите пожалуйста, а то не разбираюсь :1)Составьте программу, которая находит большее из двух введенных с клавиатуры чисел a, b и выводит его на экран?

Решите пожалуйста, а то не разбираюсь :

1)Составьте программу, которая находит большее из двух введенных с клавиатуры чисел a, b и выводит его на экран.

Числа 7 и 9

2) Составьте программу, которая находит меньшее из трёх введенных чисел a, b, c и выводит его на экран.

Числа 10, 4 и 9

3) Составьте программу определяющую, является ли введенное с клавиатуры целое число кратным 3.

Заранее спасибо : ).

Vitaymba200 9 мар. 2022 г., 01:48:45 | студенческий

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательностиНа паскале ?

Написать программу, которая вводит с клавиатуры последовательность из 5 - ти вещественных чисел ипосле ввода каждого числа выводит среднее арифметическое полученной части последовательности

На паскале (через for to do).

Drte5th 16 мая 2022 г., 00:52:55 | 10 - 11 классы

1) Составить программу, запрашивающую ввод с клавиатуры двух чисел?

1) Составить программу, запрашивающую ввод с клавиатуры двух чисел.

2) Составить программу вычисления площади треугольника по основанию а и высоте h ( формула для расчёта S = 1 / 2 * a * h).

Aoverchuk 16 апр. 2022 г., 08:21:23 | 10 - 11 классы

Составить программу?

Составить программу.

Дано число N нужно поменять порядок цифр в этом числе и вывести его.

Число N вводится с клавиатуры.

AliceTzar33 14 мая 2022 г., 17:29:25 | 10 - 11 классы

Помогите пожалуйста) информатика PascalABC1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7?

Помогите пожалуйста) информатика PascalABC

1)Составьте программу , которая выводит на экран все двухзначные числа, сумма цифр которых делится на 7.

2)Составьте программу : с клавиатуры вводятся два натуральных числа x и y.

Вывести на экран все четные числа на отрезке [x, y] и подсчитать сумму этих чисел.

Miks86 10 февр. 2022 г., 18:30:48 | 10 - 11 классы

Написать программу на С + + 3?

Написать программу на С + + 3.

Известен факториал числа (вводится с клавиатуры).

Найти это число.

На этой странице находится ответ на вопрос 16. Составьте программу для вычисления числа n : n = 1∙2∙3∙…∙х?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.