Имеется задание и код, немного отличающийся от нужного по заданию?

Информатика | 5 - 9 классы

Имеется задание и код, немного отличающийся от нужного по заданию.

Необходимо отредактировать код.

Задание :

В поле ввода edtVvod вводится строка.

Необходимо дописать процедуру обработки нажатия кнопки btnRun, которая выведет в надпись lblVyvod среднеарифметическое встретившихся четных цифр, стоящих на нечетных позициях во введённой строке, если таковых нет, то результат 0.

(Вы должны написать только текст, который должен быть вставлен вместо многоточия)

procedure TForm1.

BtnRunClick(Sender : TObject) ;

var s : string ; sum, x, i, k, c : integer ; sa : real ;

begin s : = edtVvod.

Text ;

.

LblVyvod.

Caption : = FloatToStr(sa) ;

end ;

Код :

sum : = 0 ;

c : = 0 ;

sa : = 10 ;

for i : = 1 to length(s) do

begin

val(s[i], x, k) ;

if (k = 0) and (x mod 100) and (x>sum) then sum : = x ;

if (k = 0) and (x mod 100) and (x

c : = c + 1 ;

end ;

if c0 then sa : = sum / sa else sa : = 0 ;

Ответить на вопрос
Ответы (1)
NastyaSavchenko15 5 янв. 2022 г., 23:27:42

Procedure TForm1.

BtnRunClick(Sender : TObject) ;

var s : string ; sum, x, i, count : integer ;

begin s : = edtVvod.

Text ; lblVyvod.

Caption : = FloatToStr(0) ; sum : = 0 ; count : = 0 ; for i : = 1 to length(s) do begin if i mod 2 = 0 then Continue ; x : = StrToInt(s[i]) ; if x mod 2 = 1 then Continue ; sum : = sum + x ; count : = count + 1 ; end ; if count > 0 then lblVyvod.

Caption : = FloatToStr(sum / count) ;

end ;

убрала кое что ненужное

отформатировала

увы проверить негде, так что на ваш страх и риск.

Логика правильная.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Малой2000 12 мар. 2022 г., 05:10:32 | студенческий

А как быть с этим?

А как быть с этим?

Определите пожалуйста, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 120 :

var i, k : integer ;

function F(x : integer) : integer ;

begin if x < 1 then F : = 1 else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin i : = 0 ; readln(K) ; while F(i) < K do i : = i + 1 ; writeln(i) ;

end.

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Millan11 20 мар. 2022 г., 06:32:45 | 10 - 11 классы

Как исправить?

Как исправить?

23242.

Pas(18) : Ошибка времени выполнения : Входная строка имела неверный формат.

Вот код :

var f1 : text ; b, c, i : integer ; d : real ;

begin randomize ; assign(f1, '6161.

Txt') ; rewrite(f1) ; for i : = 1 to 100 do begin c : = random(1001) ; write(f1, c, ' ') end ; close(f1) ; reset(f1) ; while not EOln(f1) do begin read(f1, d) ; c : = round(d) ; if (c div 3 = 0) and (c div 10 div 10 div 10 = 0) and (c = 0) then b : = c ; end ; close(f1) ; append(f1) ; writeln(f1) ; writeln(f1) ; if b 0 then writeln(f1, 'Число ', b, ' является трехзначным и нацело делится на 3') else writeln(f1, 'В файле нет трехзначных чисел, которые нацело делятся на 3') ; close(f1) ;

end.

Наатт 18 янв. 2022 г., 09:13:42 | 5 - 9 классы

Перевести из Pascal в Сvar a, b : longint ; n, m : byte ;begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0?

Перевести из Pascal в С

var a, b : longint ; n, m : byte ;

begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0 do begin a : = a * 10 + b mod 10 ; b : = b div 10 ; end ; writeln(a) ;

end.

78FF 20 апр. 2022 г., 21:22:25 | 10 - 11 классы

Переделать из программы Pascal в C#Задание : Шифр атбашconst s1 = 'ABCDEFGHIJKLMNOPQRSTUVWXYZабвгдеёжзийклмнопрстуфхцчшщъыьэюя' ; s2 = 'ZYXWVUTSRQPONMLKJIHGFEDCBAяюэьыъщшчцхфутсрпонмлкйизжедгвба' ;var?

Переделать из программы Pascal в C#

Задание : Шифр атбаш

const s1 = 'ABCDEFGHIJKLMNOPQRSTUVWXYZабвгдеёжзийклмнопрстуфхцчшщъыьэюя' ; s2 = 'ZYXWVUTSRQPONMLKJIHGFEDCBAяюэьыъщшчцхфутсрпонмлкйизжедгвба' ;

var i, p : integer ; s : string ;

begin Write('Введите текст : ') ; Readln(s) ; for i : = 1 to Length(s) do begin p : = Pos(s[i], s1) ; if p>0 then s[i] : = s2[p] end ; Writeln('Результат : ', s)

end.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

1q22 11 июн. 2022 г., 12:03:16 | 5 - 9 классы

Нужно составить описание к программеprogram pr1 ;const n = 5 ;var a : array[1?

Нужно составить описание к программе

program pr1 ;

const n = 5 ;

var a : array[1.

N] of integer ;

i, s1, s2 : integer ;

begin

randomize ;

s1 : = 0 ;

s2 : = 0 ;

for i : = 1 to n do begin

a[i] : = random(20) - 8 ;

writeln(a[i] : 4, ' Порядковый номер ', i) ;

end ;

writeln ;

for i : = 1 to n do begin

if i mod 20 then s1 : = s1 + sqr(a[i]) * a[i] ;

if i mod 2 = 0 then s2 : = s2 + sqr(a[i]) ;

end ;

writeln('Сумма 1 = ', s1) ;

writeln('Сумма 2 = ', s2) ;

end.

На этой странице сайта вы найдете ответы на вопрос Имеется задание и код, немного отличающийся от нужного по заданию?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.