Пожалуйста помогите?

Информатика | 5 - 9 классы

Пожалуйста помогите!

Найдите исправьте все ошибки, допущенные в этой программе.

Запишите программу без ошибок.

Var a ; b ; c : Integer ; d : real ;

Begin

Writeln('b = ?

', b)

Readln(b) ;

a = 10 ;

с : ab

Writeln(' a x b' равно' C) ;

d : = c div b ;

writeln(d)

End.

Ответить на вопрос
Ответы (1)
Зита5 8 янв. 2022 г., 22:09:44

Var a, b, c : integer ; d : integer ;

Begin

Writeln('b = ?

', b) ;

Readln(b) ;

a : = 10 ;

с : = a * b ;

Writeln(' a x bравно', c) ;

d : = c div b ;

writeln(d)

End.

Ошибки я старалась выделить жирным.

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Элькаспросит 31 янв. 2022 г., 03:16:43 | 5 - 9 классы

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскалеVar a, b : integer ;begina : = 1333 ;b : = (a div 100) * 13 + 5 :a : = (10 * b - a) mod 100 ;writeln (`a = `, a?

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскале

Var a, b : integer ;

begin

a : = 1333 ;

b : = (a div 100) * 13 + 5 :

a : = (10 * b - a) mod 100 ;

writeln (`a = `, a) ;

writeln (`b = `, b) ;

end.

Nastjakijam 28 янв. 2022 г., 23:03:19 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число , эта программа

печатает два числа, a и b.

Укажите наибольшее из чисел , при вводе которых алгоритм печатает сначала 2, а потом 8.

Var x, a, b : integer ;

begin

readln(x) ;

a : = 0 ; b : = 0 ;

while x > 0 do begin

a : = a + 1 ;

b : = b + (x mod 100) ;

x : = x div 100 ;

end ;

writeln(a) ; write(b) ;

end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Agent2013 10 мар. 2022 г., 07:17:40 | студенческий

Дайте ответ пожалуйста?

Дайте ответ пожалуйста!

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, и .

Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом10.

Var x, a, b : integer ;

begin readln(x) ; a : = 0 ; b : = 1 ; while x > 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ;

end.

Мулкина 10 янв. 2022 г., 15:58:17 | 1 - 4 классы

Какие операторы не правильные?

Какие операторы не правильные?

(В паскале) Преобразуйте в правильную программу.

Program qq ; var a, b : integer ; x, y : real ; begin a : = 5 ; 10 : = x ; y : = 7, 8 ; b : = 2.

5 ; x : = 2 * (a + y) ; a : = b + x ; end.

Froggy2005 25 февр. 2022 г., 23:54:15 | 5 - 9 классы

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Var n : integer ;

begin

readln(n) ;

writeln(n div 100 mod 10 * 1000 + n div 10 mod 10 * 100 + n mod 10 * 10 + n div 1000) ;

end.

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

Daydostup 3 апр. 2022 г., 20:59:45 | 5 - 9 классы

Дана программа :Program chisla ;vara, b, c, d : integer ;begin writeln ('Введите a : ') ; readln (a) ; writeln ('Введите b : ') ; readln (b) ; c : = sqr(a + b) ; d : = sqr(a) + sqr(b) ; writeln ('Квад?

Дана программа :

Program chisla ;

var

a, b, c, d : integer ;

begin writeln ('Введите a : ') ; readln (a) ; writeln ('Введите b : ') ; readln (b) ; c : = sqr(a + b) ; d : = sqr(a) + sqr(b) ; writeln ('Квадрат суммы : ', c) ; writeln ('Сумма квадратов : ', d) ;

End.

СОСТАВЬТЕ БЛОК - СХЕМУ.

На этой странице находится ответ на вопрос Пожалуйста помогите?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.