Дана программа :Program chisla ;vara, b, c, d : integer ;begin writeln ('Введите a : ') ; readln (a) ; writeln ('Введите b : ') ; readln (b) ; c : = sqr(a + b) ; d : = sqr(a) + sqr(b) ; writeln ('Квад?

Информатика | 5 - 9 классы

Дана программа :

Program chisla ;

var

a, b, c, d : integer ;

begin writeln ('Введите a : ') ; readln (a) ; writeln ('Введите b : ') ; readln (b) ; c : = sqr(a + b) ; d : = sqr(a) + sqr(b) ; writeln ('Квадрат суммы : ', c) ; writeln ('Сумма квадратов : ', d) ;

End.

СОСТАВЬТЕ БЛОК - СХЕМУ.

Ответить на вопрос
Ответы (1)
F1NN1 3 апр. 2022 г., 20:59:50

Блок - схема - в прилагаемом файле.

Элькаспросит 31 янв. 2022 г., 03:16:43 | 5 - 9 классы

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскалеVar a, b : integer ;begina : = 1333 ;b : = (a div 100) * 13 + 5 :a : = (10 * b - a) mod 100 ;writeln (`a = `, a?

Определите что будет напечатано в результате выполнения алкоритма, записанного на паскале

Var a, b : integer ;

begin

a : = 1333 ;

b : = (a div 100) * 13 + 5 :

a : = (10 * b - a) mod 100 ;

writeln (`a = `, a) ;

writeln (`b = `, b) ;

end.

Кротова 8 янв. 2022 г., 22:09:42 | 5 - 9 классы

Пожалуйста помогите?

Пожалуйста помогите!

Найдите исправьте все ошибки, допущенные в этой программе.

Запишите программу без ошибок.

Var a ; b ; c : Integer ; d : real ;

Begin

Writeln('b = ?

', b)

Readln(b) ;

a = 10 ;

с : ab

Writeln(' a x b' равно' C) ;

d : = c div b ;

writeln(d)

End.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Idibek1 17 мар. 2022 г., 17:00:02 | 5 - 9 классы

Program Dvch ;var N : integer ;beginwriteln('Введите число N') ;readln(N) ;If (N>9) and (N?

Program Dvch ;

var N : integer ;

begin

writeln('Введите число N') ;

readln(N) ;

If (N>9) and (N.

Doooooos2016 24 мар. 2022 г., 08:38:40 | 10 - 11 классы

СрочноProgram sredarifment ;Var a : array[1?

Срочно

Program sredarifment ;

Var a : array[1.

10] of real ;

i, k : integer ;

C, S, sred : real ;

Begin

For i : = 1 to 10 do begin write ('a[', i, '] = ') ; readln (a[i]) ; end ;

write('введите C : ') ; readln (C) ;

For i : = 1 to 10 do begin If a[i]>C then begin S = S + a[i] ; K = K + 1 ; end ; end ;

sred = S / k ;

Writeln('среднее арифметическое чисел, превосходящих ', C, ' равно ', sred) ;

End.

Помогите чтобы программа запускалась.

Выходит что не верно.

12345358 20 мая 2022 г., 19:01:29 | 5 - 9 классы

Нужно составить описание к программе(Задание - Составить список, содержащийсведения об n студентах?

Нужно составить описание к программе(Задание - Составить список, содержащий

сведения об n студентах.

Для каждого студента

должно быть указано : -

фамилия ; -

ИНН ; -

дата рождения ; -

год поступления в университет ; -

курс ; -

группа ; -

оценки текущей сессии по трем предметам.

Информацию о каждом студенте оформить в виде записи.

Совокупность записей объединить в массив.

Составить программу, которая

обеспечивает ввод исходных данных, обработку и вывод на экран информации в

соответствии с вариантом задания.

Вывести на экран фамилии трех самых молодых студентов)

program pr5 ;

const N = 5 ;

type student = Record fam : String ; inn : string ; Year : integer ; god_p : integer ; kurs : 1.

5 ; gruppa : string ; b1, b2, b3 : 1.

5 ; End ;

var spisok : Array [1.

N] Of student ; FF : Text ; b, a : string ; i, j, k1 : Integer ;

begin for i : = 1 To N Do with spisok[i] Do begin Writeln('Введите фамилию') ; Readln(fam) ; Writeln('Введите ИНН') ; Readln(inn) ; Writeln('Введите три оценки') ; Readln(b1, b2, b3) ; Writeln('год поступления') ; Readln(god_p) ; Writeln('курс') ; Readln(kurs) ; Writeln('группа') ; Readln(gruppa) ; Writeln('Введите дату рождения(GGGGMMDD)без пробелов и точек всё пишем слитно(19971231)') ; Readln(Year) ; end ; for i : = 1 to n - 1 do for j : = 1 to n - i do if spisok[j].

Year > spisok[j + 1].

Year then begin k1 : = spisok[j].

Year ; a : = spisok[j].

Fam ; spisok[j].

Year : = spisok[j + 1].

Year ; spisok[j].

Fam : = spisok[j + 1].

Fam ; spisok[j + 1].

Year : = k1 ; spisok[j + 1].

Fam : = a end ; writeln ; for i : = 1 to 3 do begin write(spisok[i].

Fam) ; writeln ; end ;

end.

Дианочка11111111 26 мар. 2022 г., 14:25:30 | 5 - 9 классы

Program numb19 ;Var a, b, c, d, e, f, g : integer ;BeginReadln(a) ; if a mod 2 = 0 then Writeln('da')else Writeln('NO') ; if a div 10 then Writeln('2 zn')else Writeln('1 zn') ;end?

Program numb19 ;

Var a, b, c, d, e, f, g : integer ;

Begin

Readln(a) ; if a mod 2 = 0 then Writeln('da')

else Writeln('NO') ; if a div 10 then Writeln('2 zn')

else Writeln('1 zn') ;

end.

В чём ошибка?

Антонинка1230 27 июн. 2022 г., 21:01:21 | 10 - 11 классы

Program a2 ;var a, b, c, min : real ;beginwriteln('Введите три числа') ;readln(a, b, c) ;min : = a ;if bif cwriteln('min = ', min)end?

Program a2 ;

var a, b, c, min : real ;

begin

writeln('Введите три числа') ;

readln(a, b, c) ;

min : = a ;

if b

if c

writeln('min = ', min)

end.

КАК РЕШАТЬ?

А)а = 10, b = 5 и с = 1

Б)а = 10, b = 5 и с = 7

В)а = 2, b = 10, с = 5.

1q22 11 июн. 2022 г., 12:03:16 | 5 - 9 классы

Нужно составить описание к программеprogram pr1 ;const n = 5 ;var a : array[1?

Нужно составить описание к программе

program pr1 ;

const n = 5 ;

var a : array[1.

N] of integer ;

i, s1, s2 : integer ;

begin

randomize ;

s1 : = 0 ;

s2 : = 0 ;

for i : = 1 to n do begin

a[i] : = random(20) - 8 ;

writeln(a[i] : 4, ' Порядковый номер ', i) ;

end ;

writeln ;

for i : = 1 to n do begin

if i mod 20 then s1 : = s1 + sqr(a[i]) * a[i] ;

if i mod 2 = 0 then s2 : = s2 + sqr(a[i]) ;

end ;

writeln('Сумма 1 = ', s1) ;

writeln('Сумма 2 = ', s2) ;

end.

На этой странице сайта размещен вопрос Дана программа :Program chisla ;vara, b, c, d : integer ;begin writeln ('Введите a : ') ; readln (a) ; writeln ('Введите b : ') ; readln (b) ; c : = sqr(a + b) ; d : = sqr(a) + sqr(b) ; writeln ('Квад? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.