Дайте ответ пожалуйста?

Информатика | студенческий

Дайте ответ пожалуйста!

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, и .

Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом10.

Var x, a, b : integer ;

begin readln(x) ; a : = 0 ; b : = 1 ; while x > 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ;

end.

Ответить на вопрос
Ответы (1)
Lolka1799 10 мар. 2022 г., 07:17:46

Прогоном.

A = 3 = > x больше 64 и не более 511(первое число, при котором с условием x mod 8>0 цикл запускается 3 раза и 511 последнее из таких чисел)

сам искомый иск наименьший = 106.

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Nastjakijam 28 янв. 2022 г., 23:03:19 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число , эта программа

печатает два числа, a и b.

Укажите наибольшее из чисел , при вводе которых алгоритм печатает сначала 2, а потом 8.

Var x, a, b : integer ;

begin

readln(x) ;

a : = 0 ; b : = 0 ;

while x > 0 do begin

a : = a + 1 ;

b : = b + (x mod 100) ;

x : = x div 100 ;

end ;

writeln(a) ; write(b) ;

end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Froggy2005 25 февр. 2022 г., 23:54:15 | 5 - 9 классы

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Var n : integer ;

begin

readln(n) ;

writeln(n div 100 mod 10 * 1000 + n div 10 mod 10 * 100 + n mod 10 * 10 + n div 1000) ;

end.

Ksa84 3 янв. 2022 г., 21:12:08 | 5 - 9 классы

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0?

1. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).

2. Что будет на экране после выполнения программы

Var I, s, k : integer ;

Begin .

S : = 0 ;

for i : = 0 to 10 do

s : = s - i + 5 ; writeln(s) ;

End.

Наатт 18 янв. 2022 г., 09:13:42 | 5 - 9 классы

Перевести из Pascal в Сvar a, b : longint ; n, m : byte ;begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0?

Перевести из Pascal в С

var a, b : longint ; n, m : byte ;

begin readln(a) ; readln(n) ; b : = 0 ; while a > 0 do begin m : = a mod 10 ; if m n then b : = b * 10 + m ; a : = a div 10 ; end ; while b > 0 do begin a : = a * 10 + b mod 10 ; b : = b div 10 ; end ; writeln(a) ;

end.

SamorodovaA 2 мар. 2022 г., 06:23:33 | 5 - 9 классы

Составить программу которая вводит два числа и печатает какое из них больше или они равны?

Составить программу которая вводит два числа и печатает какое из них больше или они равны.

Через Бейсик.

На этой странице сайта вы найдете ответы на вопрос Дайте ответ пожалуйста?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников студенческий. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.