Какие числа можно получить при вычислении выражения x mod 3?

Информатика | 5 - 9 классы

Какие числа можно получить при вычислении выражения x mod 3?

Ответить на вопрос
Ответы (1)
Fidan290 2 февр. 2022 г., 00:38:13

Mod - это Остаток от деления a на b

при делении на целое число могут получится остатки меньшие самого числа или остаток 0 когда делится нацело, значит

остаток должен быть меньше 3

это 1, 2.

Stefanida1Qw 5 янв. 2022 г., 14:17:42 | 5 - 9 классы

Создайте программу вычисления и вывода на экран степеней числа "3" до 7 степени?

Создайте программу вычисления и вывода на экран степеней числа "3" до 7 степени.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Serge12 12 янв. 2022 г., 22:07:37 | 5 - 9 классы

СРОЧНООО , ПОМОГИИИТЕ((((Ниже записана программа?

СРОЧНООО , ПОМОГИИИТЕ((((

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, L и M .

Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x > 0 do begin L : = L + 1 ; if x mod 2 = 0 then M : = M + x mod 10 ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

ВикторияРепина 26 февр. 2022 г., 04:42:13 | 5 - 9 классы

16. Составьте программу для вычисления числа n : n = 1∙2∙3∙…∙х?

16. Составьте программу для вычисления числа n : n = 1∙2∙3∙…∙х.

Число Х вводится с клавиатуры.

Mi616 27 февр. 2022 г., 04:27:02 | 10 - 11 классы

Помогите пожалуйста123 mod 10 + 123 div 10 mod 10 + 123 div 10 div 10 mod 10 =?

Помогите пожалуйста

123 mod 10 + 123 div 10 mod 10 + 123 div 10 div 10 mod 10 =.

Froggy2005 25 февр. 2022 г., 23:54:15 | 5 - 9 классы

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Какое число необходимо подать на вход программе, чтобы было выведено число 6387?

Var n : integer ;

begin

readln(n) ;

writeln(n div 100 mod 10 * 1000 + n div 10 mod 10 * 100 + n mod 10 * 10 + n div 1000) ;

end.

AngelinaJi 27 апр. 2022 г., 02:55:37 | 5 - 9 классы

Составьте программы на Паскаль для вычисления выражений ?

Составьте программы на Паскаль для вычисления выражений :

Илья111111333 16 апр. 2022 г., 19:14:29 | 10 - 11 классы

Вычислить значения выражений : 100 div 10 mod 3?

Вычислить значения выражений : 100 div 10 mod 3.

Alieks00 3 июн. 2022 г., 00:36:52 | 5 - 9 классы

Вам нужно умножить некоторое большое число Х на 15?

Вам нужно умножить некоторое большое число Х на 15.

У вас есть калькулятор, но на калькуляторе сломались все кнопки операций, кроме сложения.

Поэтому вы можете только складывать разные числа (например, можно сложить число Х и число Х, тогда получится 2Х, затем можно сложить число 2Х и 2Х и получится 4Х, а можно сложить 2Х и Х и получится 3 Х, то есть можно складывать любые ранее полученные числа между собой).

Определите, при помощи какого минимального числа сложений можно получить число 15Х.

Приведите последовательность операций, при помощи которых можно получить число 15Х за указанное число сложений.

Kpop111 3 мая 2022 г., 19:56:07 | 10 - 11 классы

Записать в развернутой форме восьмеричное число и, произведя вычисления, выразить в десятичной системе счисления : 473?

Записать в развернутой форме восьмеричное число и, произведя вычисления, выразить в десятичной системе счисления : 473.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Какие числа можно получить при вычислении выражения x mod 3?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.