Помогите написать программы в Pascal ABC1?

Информатика | 5 - 9 классы

Помогите написать программы в Pascal ABC

1.

Найти сумму s = 3 / 1 + 6 / 14 + 9 / 20.

+ 99 / 200

2.

Среди 3 - х значных чисел найти и вывести на экран числа, которые равны сумме кубов своих цифр.

Ответить на вопрос
Ответы (1)
Zelya17 2 авг. 2021 г., 02:13:46

1. var i : integer ; s : real ;

begin

s : = 3 ;

for i : = 2 to 33 do s : = s + 3 * i / (2 * 3 * i + 2) ;

writeln('s = ', s : 6 : 4) ;

end.

Результат :

s = 18.

5161

2.

Var i1, i2, i3 : integer ;

begin

for i1 : = 1 to 9 do

for i2 : = 0 to 9 do for i3 : = 0 to 9 do if i1 * i1 * i1 + i2 * i2 * i2 + i3 * i3 * i3 = i1 * 100 + i2 * 10 + i3 then write(i1 * 100 + i2 * 10 + i3, ' ') ;

end.

Результат :

153

370

371

407.

ЛиСЁн0К1 5 июн. 2021 г., 02:25:19 | 1 - 4 классы

"среди чисел a, b, c, d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC?

"среди чисел a, b, c, d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC.

Иринка18051998 29 янв. 2021 г., 10:20:22 | 10 - 11 классы

Помогите написать программудано 4х значное число вывести на экран монитора первую и третью цифры, произведениэ этих цифр?

Помогите написать программу

дано 4х значное число вывести на экран монитора первую и третью цифры, произведениэ этих цифр.

Artemkokorev 8 янв. 2021 г., 08:36:58 | 5 - 9 классы

Циклы (for and while) в Pascal ABC?

Циклы (for and while) в Pascal ABC.

Помогите решить задачу, пожалуйста.

Составьте программу, которая выводит на экран все двузначные числа, сумма цифр которых четная.

Satanika24 21 июл. 2021 г., 14:47:29 | 5 - 9 классы

Найти и вывести на экран все целые числа из промежутка от 1 до K, в десятичной записи которых есть цифра 7?

Найти и вывести на экран все целые числа из промежутка от 1 до K, в десятичной записи которых есть цифра 7.

K вводится с клавиатуры

Pascal ABC.

Sivach142 22 июл. 2021 г., 10:16:43 | 5 - 9 классы

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal)?

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal).

Мишель4444 20 июн. 2021 г., 07:19:39 | 5 - 9 классы

1. Составьте программу в Pascal ABC?

1. Составьте программу в Pascal ABC.

Известно, что X кг конфет стоит A рублей.

Определить, сколько стоит 1 кг и Y кг этих же конфет.

2. Составьте программу в Pascal ABC.

Дано двузначное число.

Найти сумму и произведение его цифр.

3. Составьте программу в Pascal ABC.

Дано двузначное число.

Вывести число, полученное при перестановке цифр.

Русалина3 3 июн. 2021 г., 08:50:26 | 10 - 11 классы

Напишите на паскале (АВС)?

Напишите на паскале (АВС).

Задание : Среди всех четырехзначных натуральных чисел вывести на экран "особо счастливые", у которых сумма цифр в четных разрядах равна сумме цифр в нечетных.

Бааарссс 6 июн. 2021 г., 23:56:07 | 5 - 9 классы

Написать программу на нахождение суммы отрицательных четных чисел на языке Pascal ABC?

Написать программу на нахождение суммы отрицательных четных чисел на языке Pascal ABC.

Krenshotka 11 дек. 2021 г., 19:14:22 | студенческий

Найти все натуральные числа от 1 до N, представимые в виде суммы кубов двух натуральных чиселpascal abc?

Найти все натуральные числа от 1 до N, представимые в виде суммы кубов двух натуральных чисел

pascal abc.

Ban1984 17 авг. 2021 г., 07:16:55 | 5 - 9 классы

Написать программу в Pascal ABC?

Написать программу в Pascal ABC.

Вычислить значение функции y(x) и вывести его на экран.

На этой странице сайта вы найдете ответы на вопрос Помогите написать программы в Pascal ABC1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.