Найти и вывести на экран все целые числа из промежутка от 1 до K, в десятичной записи которых есть цифра 7?

Информатика | 5 - 9 классы

Найти и вывести на экран все целые числа из промежутка от 1 до K, в десятичной записи которых есть цифра 7.

K вводится с клавиатуры

Pascal ABC.

Ответить на вопрос
Ответы (1)
Pocik35 21 июл. 2021 г., 14:47:33

Функция isSevenHere возвращает истину, если в числе есть семерка, и ложь - если ее нет.

В цикле for перебираем все значения от 1 до K (число, введенное с клавиатуры), и выводим на экран только те, где есть семерка.

Код программы :

function isSevenHere(number : integer) : boolean ; var digit : integer ; begin Result : = true ; while (number > 0) do begin digit : = number mod 10 ; if (digit = 7) then exit ; number : = number div 10 ; end ; Result : = false ; end ;

var i, k : integer ; begin write('Введите k : ') ; readln(k) ; for i : = 1 to k do if (isSevenHere(i) = true) then write(i, ' ') ; end.

Астерия 11 авг. 2021 г., 10:56:52 | 10 - 11 классы

Вводится число с клавиатуры?

Вводится число с клавиатуры.

Необходимо вывести его на экран и выяснить четное оно или нет.

Aijaka1980 14 апр. 2021 г., 09:42:08 | 10 - 11 классы

Вывести на экран значение n?

Вывести на экран значение n!

, n – целое число, вводимое с клавиатуры.

Саноро1 21 июн. 2021 г., 15:22:50 | 5 - 9 классы

Составьте программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы?

Составьте программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы.

На языке Pascal ABC.

Срочно!

Шпатель 2 авг. 2021 г., 06:56:15 | 5 - 9 классы

Даю 15 баллов?

Даю 15 баллов!

Pascal ABC составьте программу в которой осуществляется ввод двух целых чисел с клавиатуры и выводом на экран монитора значения их выражения.

Ghdv 22 мая 2021 г., 11:57:22 | 5 - 9 классы

С клавиатуры вводят 3 числа?

С клавиатуры вводят 3 числа.

Определить существует ли треугольник с такими сторонами.

Если да - найти его площадь.

Если нет - вывести сообщение об этом на экран.

Barbara944 2 мар. 2021 г., 03:59:12 | 5 - 9 классы

1)Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи?

1)Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.

2)Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Сделайте в Паскале Pascal.

Vlasoffmisha20 20 сент. 2021 г., 23:42:30 | 5 - 9 классы

С клавиатуры вводятся два целых положительных числа?

С клавиатуры вводятся два целых положительных числа.

Найти их наименьшее общее кратное.

Pascal ABC

функцией.

Kyzman789rustam 10 окт. 2021 г., 14:37:26 | 5 - 9 классы

С клавиатуры вводится целое число?

С клавиатуры вводится целое число.

Если оно двухзначное, то вывести удвоеную сумму на экран.

Помоги пожалуйста.

Спасибо.

KrytoichelovekGfgfh 18 июн. 2021 г., 01:28:41 | 10 - 11 классы

Помогите по ПаскалюС клавиатуры вводится вещественное число?

Помогите по Паскалю

С клавиатуры вводится вещественное число.

Вывести сумму трёх его первых цифр после десятичной точки.

Dubinina9818 29 дек. 2021 г., 15:17:33 | 5 - 9 классы

НА ПАСКАЛЕ С клавиатуры вводится вещественное число?

НА ПАСКАЛЕ С клавиатуры вводится вещественное число.

Вывести сумму

трёх его первых цифр после десятичной точки.

СРОЧНО, ПОЖАЛУЙСТА.

На этой странице сайта вы найдете ответы на вопрос Найти и вывести на экран все целые числа из промежутка от 1 до K, в десятичной записи которых есть цифра 7?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.