"среди чисел a, b, c, d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC?

Информатика | 1 - 4 классы

"среди чисел a, b, c, d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC.

Ответить на вопрос
Ответы (1)
Котята66 5 июн. 2021 г., 02:25:21

Var a, b, c, d : real ; s : integer ;

begin Write('Введите a b c d : ') ; Read(a, b, c, d) ; if frac(a) = 0 then s : = Trunc(a) else s : = 0 ; if frac(b) = 0 then s : = s + Trunc(b) ; if frac(c) = 0 then s : = s + Trunc(c) ; if frac(d) = 0 then s : = s + Trunc(d) ; Writeln('S = ', s)

end.

Пример

Введите a b c d : 2.

5 6 - 3 - 1.

75

S = 3.

Zlod247 11 февр. 2021 г., 01:12:10 | 5 - 9 классы

PASCAL ABC : Составьте программу вычисления суммы четных чисел в диапазоне от 1 до 100?

PASCAL ABC : Составьте программу вычисления суммы четных чисел в диапазоне от 1 до 100.

Саноро1 21 июн. 2021 г., 15:22:50 | 5 - 9 классы

Составьте программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы?

Составьте программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы.

На языке Pascal ABC.

Срочно!

Шпатель 2 авг. 2021 г., 06:56:15 | 5 - 9 классы

Даю 15 баллов?

Даю 15 баллов!

Pascal ABC составьте программу в которой осуществляется ввод двух целых чисел с клавиатуры и выводом на экран монитора значения их выражения.

Elizaveta19062001 9 сент. 2021 г., 01:04:27 | 5 - 9 классы

Pascal, цикл для, составить программу?

Pascal, цикл для, составить программу.

1)Последовательно вводятся 10 целых чисел.

Найти среднее арифметическое этих чисел.

Нисарпро 2 мая 2021 г., 00:03:43 | 10 - 11 классы

Составьте программу нахождения суммы всех целых чисел в диапазоне от - 5 до n?

Составьте программу нахождения суммы всех целых чисел в диапазоне от - 5 до n.

Igoryn2815 16 авг. 2021 г., 22:18:08 | 5 - 9 классы

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль?

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль.

А) Найти сумму введенных чисел.

B) Найти количество четных отрицательных чисел среди введенных.

C) Найти максимальное число среди введенных.

Rasinmustaeva 27 мая 2021 г., 20:08:23 | 5 - 9 классы

Напишите программу в Pascal для этой задачи :Найти минимальное число в последовательности положительных чисел?

Напишите программу в Pascal для этой задачи :

Найти минимальное число в последовательности положительных чисел.

DiamonDMooN 30 авг. 2021 г., 07:49:56 | 5 - 9 классы

Напишите программу в Pascal для этой задачи :Найти среднее арифметическое и сумму последовательности положительных чисел?

Напишите программу в Pascal для этой задачи :

Найти среднее арифметическое и сумму последовательности положительных чисел.

Sivach142 22 июл. 2021 г., 10:16:43 | 5 - 9 классы

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal)?

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal).

Бааарссс 6 июн. 2021 г., 23:56:07 | 5 - 9 классы

Написать программу на нахождение суммы отрицательных четных чисел на языке Pascal ABC?

Написать программу на нахождение суммы отрицательных четных чисел на языке Pascal ABC.

Если вам необходимо получить ответ на вопрос "среди чисел a, b, c, d найти сумму целых чисел " пожалуйста составьте программу по этой задаче на pascal ABC?, относящийся к уровню подготовки учащихся 1 - 4 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.