Напишите на паскале (АВС)?

Информатика | 10 - 11 классы

Напишите на паскале (АВС).

Задание : Среди всех четырехзначных натуральных чисел вывести на экран "особо счастливые", у которых сумма цифр в четных разрядах равна сумме цифр в нечетных.

Ответить на вопрос
Ответы (1)
89174328574 3 июн. 2021 г., 08:50:31

Var i, j, k, l : integer ;

begin

for i : = 1 to 9 do for j : = 0 to 9 do for k : = 0 to 9 do for l : = 0 to 9 do if i + k = j + l then writeln(i * 1000 + j * 100 + k * 10 + l) ;

end.

Результат : 1001

1012

1023

.

9977

9988

9999.

Наташа384 24 янв. 2021 г., 10:44:40 | 10 - 11 классы

Написать функцию для нахождения суммы цифр целого числа Используя эту функцию, вывести на экран : 1)трехзначные нечетные числа, суммы цифр которых кратна 8 ; 2)те из n введенных с клавиатуры целых чис?

Написать функцию для нахождения суммы цифр целого числа Используя эту функцию, вывести на экран : 1)трехзначные нечетные числа, суммы цифр которых кратна 8 ; 2)те из n введенных с клавиатуры целых чисел, сумма цифр которых больше десяти.

Tvega649 9 янв. 2021 г., 19:58:52 | 5 - 9 классы

Вывести первые N натуральных чисел, сумма цифр которыхнечётная?

Вывести первые N натуральных чисел, сумма цифр которых

нечётная.

Паскаль.

Через вложенные циклы со счетчиком.

10246328 10 февр. 2021 г., 11:56:07 | 5 - 9 классы

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль?

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль.

Sonikpanasonik33 26 мая 2021 г., 11:04:28 | 10 - 11 классы

Дано n натуральное?

Дано n натуральное.

Найти и вывести все числа в интервале от 10 до n - 1, у которых произведение всех цифр совпадает с суммой цифр данного числа.

Если таких чисел нет вывести "Нет".

Паскаль.

Ma4newair 18 июл. 2021 г., 08:03:37 | 1 - 4 классы

Вычислить сумму цифр четырехзначного числа, которые кратны 3 паскаль?

Вычислить сумму цифр четырехзначного числа, которые кратны 3 паскаль.

Роллсп 7 окт. 2021 г., 02:26:48 | 5 - 9 классы

Найти количество четырехзначных натуральных чисел до N у которых сумма двух средних цифр равна хотя бы одной из крайних цифр?

Найти количество четырехзначных натуральных чисел до N у которых сумма двух средних цифр равна хотя бы одной из крайних цифр.

Асыланбек 24 июл. 2021 г., 13:31:26 | 5 - 9 классы

Задание 2?

Задание 2.

Составьте программу, определяющую, является ли сумма цифр данного четырехзначного числа n четным числом.

В паскале, спасибо большое.

Ramzanradzhapov 14 сент. 2021 г., 07:41:31 | 5 - 9 классы

В случайном числе от 100 до 5000 подсчитать сумму четных цифр и нечетных цифр?

В случайном числе от 100 до 5000 подсчитать сумму четных цифр и нечетных цифр.

ЧЕРЕЗ ПАСКАЛЬ.

Partyprorvox 24 дек. 2021 г., 02:32:29 | 10 - 11 классы

3. Дано натур?

3. Дано натур.

Семизначное число P.

Вычислить сумму чётных цифр числа.

Вывести на экран последовательность из четных цифр числа.

Помогите написать программу в Паскале.

Aldikm 29 авг. 2021 г., 09:10:32 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить является ли оно четырехзначным "счастливым" (т.

Е. сумма первых двух цифр равна сумме последних двух цифр.

).

Вы открыли страницу вопроса Напишите на паскале (АВС)?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.