Задача №13Даны натуральное число n и действительные числа А1, А2, …, Аn?

Информатика | 10 - 11 классы

Задача №13

Даны натуральное число n и действительные числа А1, А2, …, Аn.

Вычислить

S = (А1 + А2 + …, + Аn) + max (А1, А2, …, Аn).

Программу по паскалю срочно.

Ответить на вопрос
Ответы (1)
Klepovaok 27 июл. 2021 г., 06:54:52

Var a : array of integer ;

n, sum, max : integer ;

begin sum : = 0 ; write('Введите натуральное число n : ') ; readln(n) ; a : = new integer[n] ; write('Введите действительные числа : ') ; for var i : = 0 to a.

Length - 1 do read(a[i] ) ; write('Сумма равна : ') ; for var i : = 0 to a.

Length - 1 do sum : = sum + a[i] ; writeln(sum) ; write('Максимальный элемент равен : ') ; max : = a[0] ; for var i : = 0 to a.

Length - 1 do if a[i]>max then begin max : = a[i] ; end ; writeln(max) ; write('S = (А1 + А2 + …, + Аn) + max (А1, А2, …, Аn) = ') ; sum : = sum + max ; write(sum) ;

end.

Edotoros 11 июн. 2021 г., 09:35:24 | 10 - 11 классы

Дано натуральное число n, действительные числа А1?

Дано натуральное число n, действительные числа А1.

Аn. В последовательности получить удвоенную сумму всех положительных элементов.

Решить в Паскале.

Uigurkabahar 16 июл. 2021 г., 18:02:48 | 10 - 11 классы

Даны действительно числа x, y, z?

Даны действительно числа x, y, z.

Вычислить u = max ^ 2 (x, y, z) Программу на Паскале написать.

Помогите пожалуйста) Вообще не понимаю информатику.

Grell 9 июн. 2021 г., 16:17:10 | 10 - 11 классы

Дано натуральное число n вычислить 2 n ?

Дано натуральное число n вычислить 2 n !

Турбо паскаль Срочно.

Luizalui 15 мар. 2021 г., 17:28:18 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Даны натуральное число n, действительное число x.

Вычислить.

Vfhbflf 17 янв. 2021 г., 13:33:27 | 5 - 9 классы

Написать программу на паскалеДаны действительные числа x, y?

Написать программу на паскале

Даны действительные числа x, y.

Вычислить значение функции z = arcsin(x + y).

Ivanbest 14 дек. 2021 г., 17:05:15 | 10 - 11 классы

Даны натуральное число n и действительные числа А1, А2, …, Аn?

Даны натуральное число n и действительные числа А1, А2, …, Аn.

Вычислить

S = (А1 + А2 + …, + Аn) + max (А1, А2, …, Аn).

Сделать программу в паскалях.

Помощник42 27 июн. 2021 г., 06:35:12 | 5 - 9 классы

Срочно, кто очень хорошо знает паскаль?

Срочно, кто очень хорошо знает паскаль!

)

Задача написать на языке паскаль))

Дано натуральное число.

Верно ли, что количество всех его цифр, есть четное число?

FoxiGirl 30 окт. 2021 г., 03:27:10 | 10 - 11 классы

Помогите написать программу в паскале?

Помогите написать программу в паскале.

Задано натуральное число n.

Вычислить произведение цифр заданного числа.

Оленька9 30 сент. 2021 г., 17:19:16 | студенческий

Написать программу, Паскаль?

Написать программу, Паскаль.

Дано натуральное число N.

Вычислить S = 1!

+ 2! + 3!

+ . + n!

(n> = 1).

Madammilina13 5 нояб. 2021 г., 19:06:28 | 10 - 11 классы

Даны действительное число x и натуральное число n?

Даны действительное число x и натуральное число n.

Вычислить S = 1 + 2 / cos x + n / cos x.

Если вам необходимо получить ответ на вопрос Задача №13Даны натуральное число n и действительные числа А1, А2, …, Аn?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.