Дано натуральное число n, действительные числа А1?

Информатика | 10 - 11 классы

Дано натуральное число n, действительные числа А1.

Аn. В последовательности получить удвоенную сумму всех положительных элементов.

Решить в Паскале.

Ответить на вопрос
Ответы (1)
Кызый 11 июн. 2021 г., 09:35:25

/ / PascalABC.

NET 3.

2, сборка 1338 от 16.

11. 2016

begin var n : = ReadInteger('n = ') ; var a : = ReadSeqReal('Вводите элементы последовательности', n) ; Writeln('Удвоенная сумма положительных равна ', 2 * a.

Where(x - > ; x> ; 0).

Sum)

end.

Пример

n = 5

Вводите элементы последовательности - 3 5.

1 3. 2 - 2.

6 0

Удвоенная сумма положительных равна 16.

6.

Anytka4231 1 янв. 2021 г., 17:01:53 | 5 - 9 классы

Дано число а?

Дано число а.

Проверить, является ли оно натуральным числом.

Знаю, что натуральные числа, это те числа, которые положительные и целые, предела не имеют.

Как в Паскале написать, что данное число не может быть дробным?

Никак не доходит.

DiG631 9 февр. 2021 г., 09:34:11 | 5 - 9 классы

Дан массив натуральных чисел?

Дан массив натуральных чисел.

Найти сумму элементов кратных числу к.

Myachikovaolga 22 янв. 2021 г., 00:06:15 | 10 - 11 классы

! QBasic ?

! QBasic !

Даны действительные числа а1 , а2 , … Известно, что а1>0 и что среди а2 , а3 , … есть хотя бы одно отрицательное число.

Пусть а1 , … , аn – члены данной последовательности, предшествующие первому отрицательному члену (n заранее неизвестное).

Получить среднее арифметическое а1 , … , аn.

Nik8754 30 мар. 2021 г., 00:07:17 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найдите минимальное натуральное число, которое ровно в n раз больше суммы своих цифр Паскаль срочно.

Luizalui 15 мар. 2021 г., 17:28:18 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Даны натуральное число n, действительное число x.

Вычислить.

Rozali85 27 июл. 2021 г., 06:54:49 | 10 - 11 классы

Задача №13Даны натуральное число n и действительные числа А1, А2, …, Аn?

Задача №13

Даны натуральное число n и действительные числа А1, А2, …, Аn.

Вычислить

S = (А1 + А2 + …, + Аn) + max (А1, А2, …, Аn).

Программу по паскалю срочно.

Ivanbest 14 дек. 2021 г., 17:05:15 | 10 - 11 классы

Даны натуральное число n и действительные числа А1, А2, …, Аn?

Даны натуральное число n и действительные числа А1, А2, …, Аn.

Вычислить

S = (А1 + А2 + …, + Аn) + max (А1, А2, …, Аn).

Сделать программу в паскалях.

Evgen555 21 апр. 2021 г., 18:46:22 | студенческий

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn?

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn.

Определить количество тех членов последовательности, которые нечетны .

PascalABC.

Jkwank 8 мар. 2021 г., 01:49:12 | 10 - 11 классы

Дано натуральное число n?

Дано натуральное число n.

Найти кубический корень из суммы квадратов цифр заданного числа.

ПАСКАЛЬ.

Ивосв 27 апр. 2021 г., 02:20:25 | 10 - 11 классы

Найти положительные числа из 10 натуральных чисел?

Найти положительные числа из 10 натуральных чисел.

Паскаль!

Если вам необходимо получить ответ на вопрос Дано натуральное число n, действительные числа А1?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.