Для вводимых с клавиатуры чисел определить количество четных чисел исумму нечетных чисел?

Информатика | 10 - 11 классы

Для вводимых с клавиатуры чисел определить количество четных чисел и

сумму нечетных чисел.

Ввод чисел прекращается, когда пользователь вводит

цифру 0.

Ответить на вопрос
Ответы (1)
Shpigernastya 27 июн. 2021 г., 14:11:31

Program forZnania ;

var x, a, b : integer ;

begin

a : = 0 ;

b : = 0 ;

repeat

readln(x) ;

if x mod 2 = 0 then a : = a + 1 else b : = b + x

until x = 0 ;

a : = a - 1 ;

writeln('Количество четных чисел : ', a) ;

writeln('Сумма нечетных чисел : ', b) ;

end.

~~~~~~~

Наверное Вы удивитесь почему после цикла стоит 'a : = a - 1'?

Поясняю : когда Вы вводите последнее число 0, то программа воспринимает его за четное число и приписывает его к кол - ву четных чисел, поэто уменьшаем кол - во чет чисел на одно.

Luk57 7 мар. 2021 г., 09:36:42 | 5 - 9 классы

Паскаль?

Паскаль.

Написать программу которая запрашивает ряд чисел и считает их сумму.

Количество чисел не ограничено.

При нажатии цифры "1" - ввод чисел прекращается.

Asabirsyanova21pony 2 апр. 2021 г., 18:09:53 | 5 - 9 классы

С клавиатуры вводится произвольная последовательность положительных чисел за которыми слудет 0?

С клавиатуры вводится произвольная последовательность положительных чисел за которыми слудет 0.

Определить максимальное число в этой последовательности, количество четных чисел.

МараКоралева169 24 янв. 2021 г., 02:53:59 | 5 - 9 классы

С клавиатуры вводятся K чисел?

С клавиатуры вводятся K чисел.

Подсчитать количество отрицательных чисел и произведение нечетных.

Используемый цикл While.

Mersedesbenz2 26 янв. 2021 г., 22:36:36 | 5 - 9 классы

Pascal ?

Pascal .

С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0.

Определить количество четных чисел.

Телевизор 6 нояб. 2021 г., 15:15:39 | 5 - 9 классы

С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0?

С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0.

Определить количество четных чисел.

Напишите на языке паскаль.

SonyaGG 21 нояб. 2021 г., 02:33:05 | 5 - 9 классы

С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0?

С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0.

Определить количество четных чисел.

Напишите на языке Паскаль.

GGGFRFGTTT 22 апр. 2021 г., 14:36:39 | 5 - 9 классы

Ввод чисел от 0 до 5000 Найти количество четных и не четных чисел?

Ввод чисел от 0 до 5000 Найти количество четных и не четных чисел.

Gulenkoeva8 20 мая 2021 г., 20:04:20 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

С клавиатуры вводится строка.

Подсчитать и вывести среднее арифметическое цифр в строке.

С клавиатуры вводится строка.

Подсчитать и вывести сумму чисел в строке.

С клавиатуры вводится строка.

Подсчитать и вывести произведение четных чисел в строке, если таких чисел нет, то вывести 0.

AtlasFX 27 февр. 2021 г., 19:31:51 | 1 - 4 классы

Составьте программу?

Составьте программу.

Для вводимых с клавиатуры чисел определить количество положительных.

Ввод чисел прекращается, когда пользователь вводит 0.

Trolfeisnu 18 сент. 2021 г., 19:01:59 | 5 - 9 классы

Написать программу на языке паскаль?

Написать программу на языке паскаль.

С клавиатуры вводятся несколько натуральных целых чисел.

Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.

Например : вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14.

На этой странице вы найдете ответ на вопрос Для вводимых с клавиатуры чисел определить количество четных чисел исумму нечетных чисел?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.