СРОЧНО?

Информатика | 5 - 9 классы

СРОЧНО!

С клавиатуры вводится строка.

Подсчитать и вывести среднее арифметическое цифр в строке.

С клавиатуры вводится строка.

Подсчитать и вывести сумму чисел в строке.

С клавиатуры вводится строка.

Подсчитать и вывести произведение четных чисел в строке, если таких чисел нет, то вывести 0.

Ответить на вопрос
Ответы (1)
89194704 20 мая 2021 г., 20:04:26

2 procedure vvod(var st : string) ; begin Writeln('Введите строку') ; Readln(st) ; end ;

function SC(st : string) : integer ; var l, k, i, x, code : integer ; begin k : = 0 ; for i : = 1 to length(st) do begin val(copy(st, i, 1), x, code) ; if code = 0 then begin k : = k + x ; l : = l + 1 end ; end ; SC : = k div l ; end ;

var st1 : string ; u : real ;

begin vvod(st1) ; / / Ввод u : = SC(st1) ; / / Находим среднее арифметическое цифр в строке Writeln(u) ; / / Выводend.

ПОНЧИК000 14 июл. 2021 г., 01:50:26 | 10 - 11 классы

С клавиатуры вводят строку и слово?

С клавиатуры вводят строку и слово.

Составьте программу которая вставляет в строку заданное слово.

МілкаааР 18 июн. 2021 г., 02:47:26 | 10 - 11 классы

С клавиатуры вводится строка, дать ответ, встречается ли в ней слово "зима"?

С клавиатуры вводится строка, дать ответ, встречается ли в ней слово "зима".

Jika08 2 июл. 2021 г., 02:16:06 | 5 - 9 классы

Получить и вывести в строку на экран массив из 10 чисел с помощью генератора случайных чисел?

Получить и вывести в строку на экран массив из 10 чисел с помощью генератора случайных чисел.

Вывести на экран все элементы массива с четным индексом.

Kolqa 1 янв. 2021 г., 15:14:00 | 5 - 9 классы

Ввести строку с клавиатуры?

Ввести строку с клавиатуры.

Подсчитать сумму цифр строки.

Если цифр нет, выдать соответствующее сообщение.

Программу написать надо на C + +.

AzlagorTV 7 мар. 2021 г., 18:51:30 | 5 - 9 классы

С клавиатуры вводится l целых чисел?

С клавиатуры вводится l целых чисел.

Подсчитать кол - во печатных чисел и произведение положительных.

Afakushin 5 мар. 2021 г., 06:38:54 | 5 - 9 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

Заменить в ней слово dog на слово cat.

Sergiy123 24 окт. 2021 г., 01:08:15 | 5 - 9 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

Подсчитать сколько раз в нее входит подстрока abc.

Karinka1011 9 окт. 2021 г., 16:25:39 | 5 - 9 классы

С клавиатуры вводится строка, содержащая пример на суммирование 2 = х чисел?

С клавиатуры вводится строка, содержащая пример на суммирование 2 = х чисел.

Подсчитать сумму и вывести пример полностью.

Например, 5 + 9 = 14.

Юлия1087 25 июл. 2021 г., 16:14:16 | 5 - 9 классы

С клавиатуры вводится строка, содержащая пример на суммирование 2 = х чисел?

С клавиатуры вводится строка, содержащая пример на суммирование 2 = х чисел.

Подсчитать сумму и вывести пример полностью.

Например, 5 + 9 = 14.

Pascal ABC.

Tigr055 23 апр. 2021 г., 14:11:42 | 5 - 9 классы

ЛЮЮЮЮЮДИ СРОЧНО НУ ПРЯМ ОЧ СРОЧНО НУЖНОС клавиатуры вводится строка, состоящая из чисел, разделенных одним пробелом?

ЛЮЮЮЮЮДИ СРОЧНО НУ ПРЯМ ОЧ СРОЧНО НУЖНО

С клавиатуры вводится строка, состоящая из чисел, разделенных одним пробелом.

Составить вторую строку, которая состоит из чисел, равных сумме цифр каждого числа исходной строки.

Паскаль, на всякий случай.

Вы находитесь на странице вопроса СРОЧНО? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.