Двумерные массивы?

Информатика | 10 - 11 классы

Двумерные массивы.

Paskal Дан массив целых чисел (n = 20), заполненный случайным образом числами из промежутка [ - 45 ; 95].

1, удалить из него все элементы, кратные 7 и принадлежащие промежутку [a, b] (a и b вводить с клавиатуры) 2, вставить число k между всеми соседними элементами, которые образуют пару элементов с одинаковыми знаками (k вводить с клавиатуры) 3, переставить в обратном порядке часть массива между элементами с номерами kl и k2, включая их.

Сделать проверку корректности ввода kl и k2, если ввод неправильный, то ничего не делать.

Ответить на вопрос
Ответы (1)
Sakwoyage76 22 мая 2020 г., 23:36:15

1)

var

a, b : array [1.

100] of integer ;

i, j, k, a, b, f : integer ;

begin

randomize ;

readln(a) ;

readln(b) ;

k : = 0 ;

for i : = 1 to 20 do

begin

a[i] : = random(135) - 45 ;

f : = 0 ;

for j : = a to b do

if (a[i] = j) and (a[i] mod 7 = 0) then f : = 1 ;

if f = 0 then

begin

k : = k + 1 ;

b[k] : = a[i] ;

end ;

end ;

for i : = 1 to k do

writeln(b[i]) ;

end.

2)

var

a, b : array [1.

100] of integer ;

i, j, k : integer ;

begin

randomize ;

readln(k) ;

j : = 0 ;

for i : = 1 to 20 do

begin

a[i] : = random(135) - 45 ;

writeln(a[i]) ;

for i : = 1 to 19 do

begin

if a[i] * a[i + 1]> ; 0 then

begin

j : = j + 1 ;

b[j] : = a[i] ;

j : = j + 1 ;

b[j] : = k ;

end

else

begin

j : = j + 1 ;

b[j] : = a[i] ;

end ;

end ;

j : = j + 1 ;

b[j] : = a[20] ;

for i : = 1 to j do

writeln(b[j]) ;

3)

var

a, b : array [1.

20] of integer ;

i, j, k1, k2 : integer ;

begin

randomize ;

readln(k1) ;

readln(k2) ;

if k1< ; k2 then

begin

for i : = 1 to 20 do

begin

a[i] : = random(135) - 45 ;

writeln(a[i]) ;

end ;

for i : = 1 to k1 - 1 do

b[i] : = a[i] ;

for i : = k2 + 1 to 20 do

b[i] : = a[i] ;

j : = k2 ;

for i : = k1 to k2 do

begin

b[j] : = a[i] ;

j : = j - 1 ;

end ;

for i : = 1 to 20 do

writeln(b[i]) ;

end ;

end.

Ніка2015 4 апр. 2020 г., 06:42:29 | 10 - 11 классы

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ]?

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.

Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).

Поменять местами первый положительный и последний отрицательный элементы.

Nastenanikishina 4 нояб. 2020 г., 06:15:37 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементы массива a [1?

Составьте программу ввода с клавиатуры элементы массива a [1.

8] и вывода элементов в обратном порядке.

Tatyanan1976 27 дек. 2020 г., 13:44:03 | 10 - 11 классы

Дан массив целых чисел (n = 10), заполненный случайными числами из промежутка [ - 40, 30]?

Дан массив целых чисел (n = 10), заполненный случайными числами из промежутка [ - 40, 30].

1. удалить из него все элементы, которые состоят из одинаковых цифр(включая однозначные числа).

2. вставить число k перед всеми элементами, в которых есть цифра 1(k вводить с клавиатуры).

3. переставить первые три и последние три элемента местами, сохраняя их следование.

130880 26 нояб. 2020 г., 07:12:46 | 10 - 11 классы

Помогите решить задачи?

Помогите решить задачи!

1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести максимальный элемент данного массива и его номер.

2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести все двузначные элементы массива и их номера.

3. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести предпоследний элемент массива кратный 3 и его номер.

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Кубишка 18 июл. 2020 г., 12:57:53 | 10 - 11 классы

В массиве подсчитать : сумму чётных элементов?

В массиве подсчитать : сумму чётных элементов.

(Элементов массива : 7.

Массив вводится с клавиатуры).

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Vikulya1278 3 нояб. 2020 г., 02:30:12 | 5 - 9 классы

С клавиатуры вводится число n а за ним массив из n элементов найдите номер последнего по счету положительного элемента массива?

С клавиатуры вводится число n а за ним массив из n элементов найдите номер последнего по счету положительного элемента массива.

Yytffed 16 окт. 2020 г., 13:57:24 | 10 - 11 классы

Информатика?

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Перед вами страница с вопросом Двумерные массивы?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.