Составьте программу, которая выводит все делители натурального числа N (в паскале)?

Информатика | 5 - 9 классы

Составьте программу, которая выводит все делители натурального числа N (в паскале).

Ответить на вопрос
Ответы (1)
Папа111к 14 сент. 2021 г., 23:09:28

Var n, i : integer ;

begin

write('n = ') ;

readln(n) ;

writeln('Делители : ') ;

for i : = 1 to n div 2 do

if n mod i = 0 then write(i, ' ') ;

writeln(n) ;

end.

Пример :

n = 24

Делители :

1 2 3 4 6 8 12 24.

Wabonuzab 27 июл. 2021 г., 23:05:00 | 1 - 4 классы

Составьте программу на языке Паскаль для определения количества цифр в записи произвольного натурального числа?

Составьте программу на языке Паскаль для определения количества цифр в записи произвольного натурального числа.

( оператор while).

Мафия2002r 23 мар. 2021 г., 19:10:06 | 5 - 9 классы

Составьте программу вычисления суммы цифр введенного с клавиатуры четырёхзначного натурального числа на паскаль?

Составьте программу вычисления суммы цифр введенного с клавиатуры четырёхзначного натурального числа на паскаль.

Hgds 31 июл. 2021 г., 12:30:08 | 5 - 9 классы

Составьте программу, которая выводит на экран квадраты n первых натуральных чисел?

Составьте программу, которая выводит на экран квадраты n первых натуральных чисел.

Каролинка555 3 июл. 2021 г., 13:52:02 | 5 - 9 классы

Составьте программу которая выводит на экран квадраты n первых натуральных чисел?

Составьте программу которая выводит на экран квадраты n первых натуральных чисел.

Vladshevchuk01 5 мая 2021 г., 03:23:18 | 10 - 11 классы

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N?

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N.

Selenagomez123 21 июл. 2021 г., 12:32:22 | 5 - 9 классы

Паскаль ABC составьте программу которая проверяет равны ли 3 введённых числа и выводит на экран сообщения равны или не равны?

Паскаль ABC составьте программу которая проверяет равны ли 3 введённых числа и выводит на экран сообщения равны или не равны.

Dasha980510 30 июл. 2021 г., 17:59:16 | 5 - 9 классы

Написать программу для Паскаля?

Написать программу для Паскаля.

Вывести на экран все числа до 1000, количество делителей которых больше чем 5.

DeniskaOK 22 дек. 2021 г., 19:33:59 | 10 - 11 классы

Составить программу на паскалем, которая выводит на экран максимальное число из трех вводимых?

Составить программу на паскалем, которая выводит на экран максимальное число из трех вводимых.

1kara2190 10 окт. 2021 г., 10:55:10 | 10 - 11 классы

1) Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел?

1) Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел.

С + +

2) Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ].

C + +

3) Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .

С + +.

Kirik223 5 мая 2021 г., 14:42:59 | 10 - 11 классы

Написать программу, которая выводит числа от 1 до К (К - натуральное число) в убывающем порядке?

Написать программу, которая выводит числа от 1 до К (К - натуральное число) в убывающем порядке.

Вы перешли к вопросу Составьте программу, которая выводит все делители натурального числа N (в паскале)?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.