2) Вводится четырехзначное число с клавиатуры?

Информатика | 5 - 9 классы

2) Вводится четырехзначное число с клавиатуры.

Определить цифру тысяч, сотен, десятков и единиц.

В окне вывода должно быть так (это пример)

Введи четырехзначное число :

1234

цифра тысяч - 1

цифра сотен - 2

цифра десятков - 3

цифра единиц - 4.

Ответить на вопрос
Ответы (1)
MrNeb1z 28 мая 2021 г., 15:15:46

Var s : array[1.

4] of string = ('тысяч - ', 'сотен - ', 'десятков - ', 'единиц - ') ; nm : string ; i : integer ;

begin write('n = ') ; readln(nm) ; for i : = 1 to 4 do writeln('цифра ', s[i], nm[i]) ;

end.

N = 9214

цифра тысяч - 9

цифра сотен - 2

цифра десятков - 1

цифра единиц - 4.

Fruuuct 3 янв. 2021 г., 13:00:22 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить число сотен и тысяч в нем (т.

Е. , третью и четвёртую с конца цифры).

Bogdan1143 1 июн. 2021 г., 03:13:18 | 10 - 11 классы

С клавиатуры вводятся два трехзначных числа ?

С клавиатуры вводятся два трехзначных числа .

Выяснить , образуют ли сумма цифр сотен, сумма цифр десятков , сумма цифр единиц введенных чисел убывающую последовательность.

Варвара98765432 28 янв. 2021 г., 11:35:48 | 5 - 9 классы

Выведите число, полученное при прочтении цифр данного числа справа налево?

Выведите число, полученное при прочтении цифр данного числа справа налево.

Вводится четырехзначное число.

Паскаль абс нет Пример 1 Ввод Вывод 1234 4321.

Metrogel 7 июл. 2021 г., 22:37:42 | 5 - 9 классы

Задача на паскале?

Задача на паскале.

С клавиатуры вводится четырёхзначное число.

Найдите разность между цифрой, стоящий у него в единицах и цифрой, стоящей в десятках.

Eugene98 19 июл. 2021 г., 23:24:48 | 10 - 11 классы

С клавиатуры вводится трехзначное число?

С клавиатуры вводится трехзначное число.

Составить программу которая найдет разность цифр этого числа, стоящих в позиции единиц и сотен.

Dupot 5 апр. 2021 г., 00:08:50 | 5 - 9 классы

Дано четырехзначное число?

Дано четырехзначное число.

Определите является ли сумма цифр четной.

Papap2 18 мар. 2021 г., 05:02:00 | 5 - 9 классы

Дано натуральное трехзначное число a?

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы сумме цифр числа единиц и десятков числа а, десятков в b равно увеличенному на 2 числу десятков в числе а, а вместо единиц поставить цифру 0.

С + +.

Azhu15 15 янв. 2021 г., 19:55:16 | 10 - 11 классы

Задано шестизначное число?

Задано шестизначное число.

Составьте алгоритм нахождения цифр,

соответствующих разряду сотен и тысяч в записи этого числа.

Luna121286g 15 янв. 2021 г., 13:53:45 | 5 - 9 классы

Дано четырехзначное число?

Дано четырехзначное число.

Определить кратна ли 3 сумма его цифр.

Sobirovamariya 3 июл. 2021 г., 03:51:19 | 5 - 9 классы

С клавиатуры вводится четырехзначное число найдите сумму цифр в этом числе кратных трем?

С клавиатуры вводится четырехзначное число найдите сумму цифр в этом числе кратных трем.

На этой странице сайта, в категории Информатика размещен ответ на вопрос 2) Вводится четырехзначное число с клавиатуры?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.