Решите три задачи : линейную, с ветвлением и с циклом?

Информатика | 10 - 11 классы

Решите три задачи : линейную, с ветвлением и с циклом.

При необходимости вводите дополнительные переменные.

№1. Фильм длится К часов и М минут.

Составьте линейный алгоритм перевода длительности фильма в минуты.

№2. Фильм начинается в К часов М минут и длится А часов В минут.

Вы сможете пойти в кино, если фильм закончится за 15 минут до L часов.

Определите, пойдете вы в кино или нет.

Составьте алгоритм ветвления.

№3. Ученик 9 класса начал делать уроки ровно в 10 часов утра и потратил на это ровно М минут.

Сколько минут будет показывать минутная стрелка, когда ученик закончит выполнять все задания?

Составьте циклический алгоритм для данной задачи.

Ответить на вопрос
Ответы (1)
Vseznayka01 13 нояб. 2020 г., 10:46:16

1)

program z1 ;

var

k, m, r : integer ;

begin

write('k = ') ;

readln(k) ;

write('m = ') ;

readln(m) ;

r : = 60 * k + m ;

writeln('в минутах : ', r) ;

end.

2)

program z2 ;

var

k, m, a, b, l : integer ;

begin

write('k = ') ;

readln(k) ;

write('m = ') ;

readln(m) ;

write('a = ') ;

readln(a) ;

write('b = ') ;

readln(b) ;

write('l = ') ;

readln(l) ;

if ( (60 * k + m) + (60 * a + b) ) < (60 * l - 15) then

writeln('пойду')

else

writeln('не пойду') ;

end.

3)

program z3 ;

var

m, r : integer ;

begin

write('m = ') ;

readln(m) ;

r : = m ;

while r > = 60 do

r : = r - 60 ;

writeln('стрелка будет показывать ', r, ' минут') ;

end.

Rome341 21 янв. 2020 г., 05:39:56 | 10 - 11 классы

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество ми?

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Magda233 27 июн. 2020 г., 04:06:50 | 10 - 11 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Пример Ввод Вывод 150 2 30.

Психозuа 30 июн. 2020 г., 10:28:39 | 5 - 9 классы

Составьте пожалуйста 3 алгоритма : один с ветвлением, второй с повтором , и третий линейный алгоритм?

Составьте пожалуйста 3 алгоритма : один с ветвлением, второй с повтором , и третий линейный алгоритм.

Только , чтобы было грамотно составлено.

Borek1337 23 мая 2020 г., 21:11:32 | 5 - 9 классы

Если данное предложение представить в виде алгоритма то это будет : Если сделаешь уроки, то можешь пойти в кино, иначе сиди дома?

Если данное предложение представить в виде алгоритма то это будет : Если сделаешь уроки, то можешь пойти в кино, иначе сиди дома.

А)Линейный алгоритм В)Алгоритм с ветвлением С)Комбинированный алгоритм D)Алгоритм с циклом.

Sergey228989 24 мар. 2020 г., 22:20:56 | 5 - 9 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Входные данные Вводится число n - целое, положительное, не превышает 107.

Выходные данные Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Leonsalus 9 апр. 2020 г., 11:30:22 | 5 - 9 классы

1. Составьте программу, решающую следующую задачу : С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг?

1. Составьте программу, решающую следующую задачу : С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг.

Какое наименьшее количество (K) коробок потребуется для перевозки N килограмм конфет?

Вводимое и в ыводимое .

Для заданного числа суток определить количество часов, минут и секунд.

Вводимое количество сутокВыводимое количество часов, минут, секунд7 суток = 168 часов = 10080 минут = 604800 секунд1 сутки = 24 часов = 1440 минут = 86400 секунд10 суток = 240 часов = 14400 минут = 864000 секунд2 суток = 48 часов = 2880 минут = 172800 секунд.

Zlat0hka 5 сент. 2020 г., 08:46:17 | 5 - 9 классы

Напишите программу в Паскале Перевод из минут в часы и минуты Переведите 150 минут?

Напишите программу в Паскале Перевод из минут в часы и минуты Переведите 150 минут.

Ak07032003 2 сент. 2020 г., 05:42:44 | 10 - 11 классы

Мне нужны любые три решеные задачи на три алгоритма Линейный, ветвленый, циклический?

Мне нужны любые три решеные задачи на три алгоритма Линейный, ветвленый, циклический.

Arsentimur 12 окт. 2020 г., 11:41:26 | 5 - 9 классы

JAVA Дано число n?

JAVA Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Adelina27032003 18 дек. 2020 г., 06:50:21 | 5 - 9 классы

Составьте программу к следующей задаче :Ученик начал решать задачи данного урока программирования, когда электронные часы показывалиh1часов иmin1минут, а закончил, когда былоh2часов иmin2минут?

Составьте программу к следующей задаче :

Ученик начал решать задачи данного урока программирования, когда электронные часы показывалиh1часов иmin1минут, а закончил, когда былоh2часов иmin2минут.

Составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти задачи.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Решите три задачи : линейную, с ветвлением и с циклом?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.