Напишите функцию, вычисляющую сумму четвертых степеней цифр этого числа?

Информатика | 5 - 9 классы

Напишите функцию, вычисляющую сумму четвертых степеней цифр этого числа.

Используя эту функцию, напишите программу, выводящую все числа, равные сумме четвертых степеней своих цифр.

Ответить на вопрос
Ответы (1)
Mart1967 24 дек. 2020 г., 17:27:34

Сумма 4 - х степеней N - значного числа не превосходит N * 9 ^ 4 < ; 10000N.

С другой стороны, N - значное число больше 10 ^ (N - 2).

Для того, чтобы одно было равно другому, должно выполниться

10 ^ (N - 2) < ; 10000N, 10 ^ N < ; N * 10 ^ 6.

Так может быть, только если N < ; 7, поэтому ищем числа среди 1.

999999.

Код :

function Sum4Deg(n : integer) : integer ;

var s : integer ;

begin s : = 0 ; repeat s : = s + sqr(sqr(n mod 10)) ; n : = n div 10 ; until n = 0 ; Sum4Deg : = s ;

end ;

var i : integer ;

begin for i : = 1 to 999999 do if i = Sum4Deg(i) then writeln(i) ;

end.

Underd 22 нояб. 2020 г., 05:21:49 | 5 - 9 классы

Напишите программу возведения числа в четвертую степень за две операции?

Напишите программу возведения числа в четвертую степень за две операции.

Сделать в виде таблице а не в программе.

Stoki 20 мая 2020 г., 07:03:28 | 5 - 9 классы

Напишите программу, которая находит все числа Армстронга из диапазона от A до B?

Напишите программу, которая находит все числа Армстронга из диапазона от A до B.

Натуральное число из n цифр называется числом Армстронга, если сумма его цифр, возведенных в степень n, равна самому числу.

Ramazanovrifat 23 июн. 2020 г., 12:39:58 | 5 - 9 классы

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа?

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа.

(Pascal).

Live96 12 февр. 2020 г., 23:57:43 | 10 - 11 классы

Напишите программу, которая считает сумму цифр введенного числа(паскаль)?

Напишите программу, которая считает сумму цифр введенного числа(паскаль).

Sofapro 30 янв. 2020 г., 17:36:57 | 10 - 11 классы

Напишите функцию, которая определяет сумму цифр переданного ей числа, в системе паскаль?

Напишите функцию, которая определяет сумму цифр переданного ей числа, в системе паскаль.

Ola3331 5 нояб. 2020 г., 20:23:08 | 10 - 11 классы

PASALнаписать программу вычисляющую произведение второй и четвертой цифр четырехзначного числа?

PASAL

написать программу вычисляющую произведение второй и четвертой цифр четырехзначного числа.

Нгдшнф 9 июн. 2020 г., 15:46:22 | 5 - 9 классы

Напишите программу, которая выводит сумму цифр числа 123?

Напишите программу, которая выводит сумму цифр числа 123.

Katerina2504 20 июл. 2020 г., 19:07:30 | 5 - 9 классы

Определить существует ли натуральное двузначное число равное 4 степени суммы всех своих цифр?

Определить существует ли натуральное двузначное число равное 4 степени суммы всех своих цифр.

(Паскаль).

Arininaira 17 июн. 2020 г., 08:15:08 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Составьте программу, выводящую на экран все трехзначные числа, сумма цифр которых равна 10.

19eterniti67 3 июн. 2020 г., 23:37:56 | 10 - 11 классы

Напишите ФУНКЦИЮ, которая вычисляет количество цифр числа?

Напишите ФУНКЦИЮ, которая вычисляет количество цифр числа.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Напишите функцию, вычисляющую сумму четвертых степеней цифр этого числа?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.