Напишите программу, которая считает сумму цифр введенного числа(паскаль)?

Информатика | 10 - 11 классы

Напишите программу, которая считает сумму цифр введенного числа(паскаль).

Ответить на вопрос
Ответы (1)
555556 12 февр. 2020 г., 23:57:49

Var n, sum : integer ;

begin

writeln('Vvedite chuslo') ;

readln(n) ;

repeat

sum : = sum + (n mod 10) ;

n : = n div 10 ;

until n = 0 ;

writeln('summa = ', sum) ;

end.

Ramazanovrifat 23 июн. 2020 г., 12:39:58 | 5 - 9 классы

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа?

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа.

(Pascal).

Галка1976 14 дек. 2020 г., 00:28:26 | 5 - 9 классы

Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S?

Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S.

Izavov88 12 окт. 2020 г., 23:48:38 | 10 - 11 классы

Напишите программу, которая считает количество четных цифр введенного числа?

Напишите программу, которая считает количество четных цифр введенного числа.

Andria2004 5 июн. 2020 г., 16:07:47 | 5 - 9 классы

Напишите программу, которая считает сумму цифр между 10 и 15?

Напишите программу, которая считает сумму цифр между 10 и 15.

Chernyshovaali 19 сент. 2020 г., 15:44:36 | 5 - 9 классы

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Количество цифр в числе не известно!

Число целочисленное!

Желательно с объяснениями ( вне программы ).

Заранее спасибо!

Керим1 11 авг. 2020 г., 21:30:24 | 10 - 11 классы

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры?

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.

Ilnazmutin2 16 дек. 2020 г., 07:48:32 | 5 - 9 классы

Напишите программу, которая считает сумму цифр введённого числа?

Напишите программу, которая считает сумму цифр введённого числа.

Входная строка содержит одно натуральное число.

Программа должна вывести сумму цифр введённого числа.

НА ЯЗЫКЕ PYTHON !

ТОЛЬКО PYTHON !

Harper2307 3 мая 2020 г., 15:21:01 | 5 - 9 классы

Напишите программу которая считает количество четных цифр введенного числа в паскале?

Напишите программу которая считает количество четных цифр введенного числа в паскале.

Ilia777777 17 июн. 2020 г., 20:16:59 | 5 - 9 классы

Напишите программу которая считает количество чётных цифр введённого числа?

Напишите программу которая считает количество чётных цифр введённого числа.

Super39 6 дек. 2020 г., 11:45:46 | 5 - 9 классы

Напишите программу, которая считает сумму цифр введенного числа(c + + )?

Напишите программу, которая считает сумму цифр введенного числа(c + + ).

Вопрос Напишите программу, которая считает сумму цифр введенного числа(паскаль)?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.