В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива?

Информатика | 10 - 11 классы

В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива.

На языке СИ .

Ответить на вопрос
Ответы (1)
МарьянаYouTube1 8 сент. 2020 г., 14:33:46

#include

#include

int main() { int n ; scanf("%d", &n) ; int a[n] ; int max = INT_MIN ; int n_max = 0 ; int n_min = 0 ; int min = INT_MAX ; for(int i = 0 ; i < n ; i + + ) { scanf("%d", &a[i]) ; if(a[i]%2 = = 0 && a[i] > max) { max = a[i] ; n_max = i ; } if(a[i]%2 !

= 0 && a[i] < min) { min = a[i] ; n_min = i ; } } printf("min : %d, №%d ; max : %d, №%d \ n", min, n_min, max, n_max) ; return 0 ;

}.

Een929 11 июн. 2020 г., 12:23:29 | 10 - 11 классы

Паскаль?

Паскаль.

Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

Irochka28 16 июн. 2020 г., 08:02:04 | 10 - 11 классы

Расположить элементы целочисленного массива по убыванию?

Расположить элементы целочисленного массива по убыванию.

Найти минимальный элемент.

Fiksator3780 11 дек. 2020 г., 11:00:21 | 10 - 11 классы

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов?

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов.

Известно, что в массиве есть хотя бы один нечетный элемент.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Настя122004 1 мар. 2020 г., 21:25:50 | 5 - 9 классы

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями?

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями.

Если в массиве нет элементов с четными положительными значениями, нужно вывести сообщение об этом.

С объяснением!

Виленочка 26 июл. 2020 г., 07:34:27 | 10 - 11 классы

Найти максимальный элемент одномерного массива среди элементов с четными номерами?

Найти максимальный элемент одномерного массива среди элементов с четными номерами.

(начертить схему).

Катя20045 21 апр. 2020 г., 14:50:56 | 5 - 9 классы

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера?

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера.

Hsmjh 3 февр. 2020 г., 20:38:40 | 5 - 9 классы

Дан целочисленный массив X(N, M) ?

Дан целочисленный массив X(N, M) .

Среди нечетных строк массива найти сумму четных элементов.

Смерш199 4 окт. 2020 г., 05:22:53 | 10 - 11 классы

Найти минимальный и максимальный элементы массивы(программку написать)?

Найти минимальный и максимальный элементы массивы(программку написать).

Slideq 30 окт. 2020 г., 04:08:28 | 5 - 9 классы

Найти номера минимального и максимального элементов массива, в Паскале?

Найти номера минимального и максимального элементов массива, в Паскале.

На этой странице находится вопрос В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.