1)дан массив из N элементов?

Информатика | 10 - 11 классы

1)дан массив из N элементов.

Определить сумму тех, которые четны и положительны.

2)Дан массив из n элементов.

В нем четные числа заменить на 0, нечетные на - 1, вывести на экран монитора содержимое массива до обработки и после обработки.

Ответить на вопрос
Ответы (1)
Killgod514 9 сент. 2020 г., 20:21:52

Program N ;

Var a, n, i, s : integer ;

Begin

Writeln('n = ') ; Readln(n) ;

s : = 0 ;

For i : = 1 to n do

Begin

a[i] : = random(100) ;

write(a : 4) ;

end ;

writeln ;

writeln('izmenenni massiv') ;

for i : = 1 to n do begin

If (amod 2) = 0 then

a : = 0

else

a : = 1 ;

write(a : 4) ;

end ;

readln ;

End.

Керис 2 окт. 2020 г., 15:24:46 | 5 - 9 классы

1. Дан массив С(10)?

1. Дан массив С(10).

Сформируйте из него массивы А и В, предварительно определив его длину, включая в массив А четные положительные элементы, а в массив В – нечетные отрицательные.

2. Количество посещений кабинетов врачей поликлиники хранится в массиве.

Нечетный элемент массива определяет номер кабинета, четный – количество посещений.

Определите и выведите на экран число посещений каждого кабинета и общее число посещений.

ПОЖАЛУЙСТА.

Evgeniya198 23 мар. 2020 г., 23:05:18 | 5 - 9 классы

(Паскаль)Заполнить с клавиатуры массив из 10 элементов?

(Паскаль)Заполнить с клавиатуры массив из 10 элементов.

Вывести на экран те элементы массива, которые имеют четный номер и четное значение .

Dzugaevzhora51 28 июн. 2020 г., 11:26:34 | 10 - 11 классы

Создать массив целых чисел, найти сумму четных элементов массива, результат вывести на экран?

Создать массив целых чисел, найти сумму четных элементов массива, результат вывести на экран.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

PLEIX 7 февр. 2020 г., 05:27:54 | 5 - 9 классы

Дан двумерный массив?

Дан двумерный массив.

В каждой четной строке определить и вывести количество положительных элементов.

Таантя 26 сент. 2020 г., 19:41:16 | 5 - 9 классы

1. Дан одномерный массив из N элементов?

1. Дан одномерный массив из N элементов.

Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2.

Дан одномерный массив из Н элементов.

Найти среднее арифметическое положительных четных элементов данного массива.

Maneckoba0sha 21 апр. 2020 г., 16:28:40 | 10 - 11 классы

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Yusufbek 16 мар. 2020 г., 22:47:12 | 5 - 9 классы

Массив содержит N случайных двузначных чисел?

Массив содержит N случайных двузначных чисел.

Определить сколько в данном массиве четных чисел.

Вывести все его элементы с нечетными номерами.

Если вам необходимо получить ответ на вопрос 1)дан массив из N элементов?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.