Напишите программуОпределить кол - во и сумму четных чисел ?

Информатика | 5 - 9 классы

Напишите программу

Определить кол - во и сумму четных чисел .

Последовательность чисел оканчивантся 0.

Программа должна вывести 2 числа , первое : длину, последовательность , второе число : сумму четных чисел

Числа при вводе 4, 60, 15, 0.

Ответить на вопрос
Ответы (1)
Алексей24517 24 мар. 2021 г., 10:13:31

Program n1 ;

var a, k, sum : integer ;

begin

readln(a) ;

k : = 0 ;

sum : = 0 ;

while a0 do

begin

if (a mod 2 = 0) then sum : = sum + a ;

k : = k + 1 ;

readln(a) ;

end ;

writeln(k) ;

writeln(sum) ;

end.

Karinochka98 1 янв. 2021 г., 20:55:50 | 5 - 9 классы

Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел?

Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел.

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ!

Мтчеларрпар 4 окт. 2021 г., 04:07:52 | 5 - 9 классы

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3?

Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.

Программа получает на выход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ).

Количество чисел не превышает 20.

Введенные числа [ - 30 ; 30].

Программа должна вывести одно число : количество четных чисел, кратных 3.

Буду признательна!

418269 9 янв. 2021 г., 05:16:24 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последователньость чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность)

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30 000.

Программа должна вывести два числа : сумму последовательности и количество четных чисел, кратных 5.

Пример работы программы :

Входные данные :

4

60

15

0

Выходные данные :

79

1.

Bakalu123 23 мая 2021 г., 21:42:05 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход кол - во чисел в последовательности, а затем сами числа.

В последовательности всегда имеется четное число.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное четное число.

Пример работы программы :

Входные данные Выходные данные

3 _______________42

10

99

42.

PokemonYouTube 18 авг. 2021 г., 16:12:33 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел?

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

PROST100MAG 23 июн. 2021 г., 08:37:19 | 10 - 11 классы

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6?

1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел , кратных 6.

Программа получает на вод натуральные числа, кол - во введенных чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода, не входит в последовательность).

Программа должна вывести одно число : сумма четырехзначных чисел , кратных 6.

2) Напишите программу , которая в последовательности натуральных чисел определяет максимальное число, кратно 3 и оканчивающиеся на 3.

Программа получает на вход кол - во чисел в последовательности, а заем сами числа.

В последовательности всегда имеется число, кратное 3 и оканчивающиеся на 3.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное число, кратное 3 и оканчивающиеся на 3.

Gukolga 8 июн. 2021 г., 21:10:42 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход кол - во чисел в последовательности, а затем сами числа.

В последовательности всегда имеется четное число.

Кол - во чисел не превышает 1000.

Введенные числа не превышают 30 000.

Программа должна вывести одно число - максимальное четное число.

Пример работы программы : Входные данные Выходные данные 3 _______________42 10 99 42

ну чтобы она работала , ребят , и с writeln(.

А то не понятно что куда вводить.

Kirill221102 24 дек. 2021 г., 17:04:58 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3?

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3.

Программа получает на вход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : количество четных чисел, кратных 3.

Header 12 авг. 2021 г., 09:25:30 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел , оканчивающих на 4 ?

Напишите программу, которая в последовательности натуральных чисел , оканчивающих на 4 .

Программа получает на вход количество чисел в последовательности , а затем сами числа.

В последовательности всегда имеется число , оканчивающее на 4 .

Программа должна вывести одно число - сумму чисел , оканчивающихся на 4.

MrDrosh111 29 авг. 2021 г., 19:10:11 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1.

Программа получает вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0(0 - признак окончания ввода не входит в последовательность).

Программа должна вывести одно число : сумму всех чисел кратных 7 и оканчивающихся на 1.

На этой странице находится вопрос Напишите программуОпределить кол - во и сумму четных чисел ?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.